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1. CICON Installation 
 

1.1 System requirements 

If you want to run CICON on your PC, here’s what it takes, 

Operation system: Windows 8/7/XP/2000/98SE  

Processor (CPU): Pentium 133 MHz or faster 

RAM: 64MB RAM minimum 

Free hard disk space: 13MB minimum 

Communication Port: USB port, Ethernet port or Serial port is recommended. 

 

1.2 Installation of CICON Software 

CICON software is available in our website www.cimon.com. 

You can download it free of charge at the SUPPORT → Software. 

1) Double click the installation Setup file. 

2) When End User License Agreement dialog box appears, click I accept the terms of the 

license agreement, and then click Next. 

 

3) Click Change on the installation dialog box to change the program installation 

destination folder and then click Next. 
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(Default folder is C:\CIMON\CICON as appear on the dialog box.) 

 

4) Click Install. 
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5) The progress bar appears. 

 

6) After the installation is finished, the complete InstallShield Wizard appears. 

 

7) Click Finish. 

You do not have to reboot the system to complete the installation. 
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1.3 Installation of USB Device Driver 

Windows XP: USB device driver is installed automatically when you run CICON after CICON installation. 

Windows 7 and 8: Install USB device driver as following steps: 

1) Turn PLC power on and connect PLC to PC with USB cable.  

Select [Control Panel]  [Devices and Printers]. 
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2) There is CIMON PLC in [Unspecified]. 

Click the right button of the mouse with cursor on the [CIMON PLC] and select [Properties]. 
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3) Select [Hardware] tap and click [Properties]. 

 

4) Click [Change settings] 
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5) Select [Driver] tab and click [Update Driver]. 

 

6) Select [Browse my computer for driver software] at [Update Driver Software – CIMON PLC]. 
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7) Select [Usb_Driver] folder where CICON is installed and click [Next]. 

* In case of Windows 7 64Bit, Select [Usb_Driver]  [OS_64Bit] folder. 

 

 

8) Select [Install this driver software anyway] at [Windows Security]. 
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9) The Driver Software is being installed. 

 

10) If USB Driver is installed successfully, [KDT PLC USB Loader CICON] appears. 

Click [Close] to finish installation. 
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11) If USB Driver is installed successfully, [KDT PLC USB Loader CICON] appears under [Universal 

Serial Bus Controllers]. 
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2. CIMON PLC Device Memory 

 

CIMON PLC uses 17 differently named devices. 

Each device has its own symbol and is denoted by a capital character. 

 

 

X Device (Bit / Input) 

- X device is an input contact that receives a signal from the input module. 

- It accepts the signal from the input device such as a push button switch or limit switch. 

- Since the input status of X device is stored inside the PLC, a user can use A and B contacts.  

- If used as a word type, X device can be used according to the bit device’s word usage. 

- It is a read-only device that a user cannot enter a value. 

- X Device Allocation for PLC modules (Input and special modules) other than CPU: 

1. PLC card occupies 16 points (1 Word). 
2. Input card with 16 points or less: occupies 16 points (1 Word). 
3. Input card with 32 points: occupies 32 points (2 Word). 
4. Special cards other than input cards occupy 16 points (1 Word). 

 

Example) 

 

Turning on X00 device will output Y20. 
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Y Device (Bit / Output) 

- Y device is an output contact that delivers the operation result to output devices such as solenoid 

valves, motors and lamps. 

- If used as a word type, Y device can be used according to the bit device’s word usage.  

- Y device can only use and output Contact A. 

- Y Device Allocation for PLC modules (Output and special modules) other than CPU: 

1. PLC card occupies 16 points (1 Word). 
2. Output card with 16 points or less: occupies 16 points (1 Word). 
3. Output card with 32 points: occupies 32 points (2 Word). 
4. Special cards other than output cards occupy 16 points (1 Word). 

 

Example) 

  

Turning on X00 device will output Y20. 

 

M Device (Bit / Internal Auxiliary Relay) 

- M device is an internal input and output digital device that cannot output the operation result to 

external devices. But the output in connection with I/O contacts can be made possible. 

- It can be used in applications such as intermediate data storage, virtual I/O and word data storage. 

- M device can use Contact A and B. 

 

Example) 

 

Turning on X00 device will turn on M20. SET instruction keeps M20 ON even if X00 turns OFF. 
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L Device (Bit / Link Relay) 

- L device can be used as a special contact for computer link and data link modules. 

- If not used as a link, L device can be used as same as M device. 

- If used as a word type, L device can be used according to the bit device’s word usage. 

 

Example) 

 

Turning on L00 device will send Frame No. 0 of the Program ID No. 1 and saves the sending result in 

M100 device. 

 

K Device (Bit / Latch Relay) 

- The usage of K device is very similar to M device. But K device has additional functionality of latch. 

- All data in this K device are retained even when power is OFF and CPU stops the operation. 

- If used as a word type, K device can be used according to the bit device’s word usage. 

 

Example) 

 

Turning on X04 device will turn on K24 device. 

 

F Device (Bit / Flag) 

- F Device is used as a contact for notifying PLC status, scan status, time, date and many other flags. 

- It is a read-only device that a user cannot enter a value. 

- Descriptions and variables of the F device are pre-registered. 
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Example) 

 

F10: Always ON Flag 

F11: Always OFF Flag 

F30: Major CPU Error Flag 

F31: Minor CPU Error Flag 

F110: CPU Calculation Error Flag 

 

T Device (Bit), TC (Word), TS (Word) / Timer Device 

- T device is auxiliary relay for timer instructions. 

- A user can configure 100 m/s or 10 m/s in the parameter’s timer settings. 

- T / TC / TS devices exist respectively and operate as a single unit with the same index number. 

- T device is a bit device that delivers the result value of the timer instructions. 

- TC device is a word device that shows the current time value of the timer instructions. 

- TS device is a word device that shows the setting time value of the timer instructions. 

 

Bit data type represents timer output status in LOAD instructions and timer reset output for RST 

instruction. Word data types are setting and ticking values. The set value can be written only by TIMER 

instructions (TRM, TON, TOFF, TMON, TRIG). The tick value can be modified or verified by various word 

instructions such as MOV, INC, comparative instructions and so on. 
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Symbol character for all these devices is ‘T’ in sequence programming point of view. But in 

monitoring point of view, two more symbol characters are used. ‘T’ represents the output status of 

timer, ‘TC’ represents the tick counter of timer and ‘TS’ represents set value of timer. These two new 

symbols of word are utilized in device memory monitoring window of CICON and in communication 

protocols for HMI. 

Device ‘T’ In Monitoring 

Symbols Data Types Descriptions 

T Bit The status of timer output 

TC Word The tick count of timer (0 ~ 65,535) 

TS Word The set value of timer (0 ~ 65,535) 

 

 

Example) 

  

When X00 is ON for 1000 m/s, T0 device gets turned ON and outputs Y20. 

In this example, TS 0 (Timer’s set value) is 10 while TC 0 is the time during which X00 is turned ON.   

When TC 0 “time value” reaches TS 0 “set value”, T 0 “bit device” gets turned ON. 

 

PLC Parameter Timer Setting 

- Configures the operation unit of the timer device. 

 100 mSec: configures the range of the timer whose single unit is 100 m/s. 

 10 mSec: configures the range of the timer whose single unit is 10 m/s. 
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C Device (Bit), CC (Word), CS (Word) / Counter Device 

- C device is auxiliary relay for counter instructions. 

- C / CC / CS devices exist respectively and operate as a single unit with the same index number. 

- C device is a bit device that delivers the result value of the counter instructions. 

- CC device is a word device that shows the counting value of the counter instructions. 

- CS device is a word device that shows the setting value of the counter instructions. 

 

Bit data type represents counter output status in LOAD instructions. Word data types are setting and 

counting values. The set value can be written only by COUNTER instructions (CTU, CTD, CTUD, CTR). 

The count value can be modified or verified by various word instructions such as MOV, INC, 

comparative instructions and so on. 

Symbol character for all these devices is ‘C’ in sequence programming point of view. But in monitoring 

point of view, two more symbol characters are used. ‘C’ represents just the output status of counter, 

‘CC’ represents the counted value of counter and ‘CS’ represents set value of counter. These two new 

symbols of word are utilized in device memory monitoring window of CICON and in communication 

protocols for HMI. 

Device ‘C’ In Monitoring 

Symbols Data Types Descriptions 

C Bit The status of counter output 

CC Word The counting value of counter (-32,768 ~ 32,767) 

CS Word The set value of counter (-32,768 ~ 32,767) 

 

Example) 

 

When X08 gets turned ON for 10 times, C0 will be turned ON and output Y28. 

CS0 (Counter’s set value) is 10 while CC0 is X08’s counting value. 

When CC0 “counting value” reaches CS0 “set value”, C0 “bit device” gets turned ON. 

 

 



 

20 

 

CICON USER MANUAL 

S Device (Step Controller) 

- S device is a special purpose relay for control algorithm which proceeds step by step. 

- CIMON PLC supports up to 100 cards of step controller (S00.nn ~ S99.nn). 

- Each step controller has 100 differently numbered state (Sxx.00~Sxx.99). 

- S device can be used with OUT or SET instruction. 

- OUT instruction sets (activates) one designated state and there are no restrictions on operation. 

- SET instruction also sets (activates) one designated state (assume the state number is ‘n’), however, 

with one condition that the previous state (state number ‘n-1’) must be on active state in order to 

move on to the next step. 

 

Example for SET instruction) 

 

Turning on X00 will turn on S1.1. 

Device X01 has to be turned on in order to activate S1.2. 

While S1.2 is OFF and X04 gets on, it will NOT turn on S1.5. (S1.2, S1.3 and S1.4 have to be turned on) 

When all the devices from X00 to X04 turn on, it will clear and erase all the values of Step No. 1  

(S1.00 ~ S1.99). 
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D Device (Word / Data Register) 

- D device stores internal data either in Word or Double Word. 

- It is used to read and write 16 bit (Word) and 32 bit (Double Word). 

- For 32 Bit, specified number is the lower 16 bit whereas the number + 1 is the upper 16 bit 

   Ex) Using D0010 for 32 Bit, D10 is the lower 16 bit.  

                         D11 is the upper 16 bit. 

Example) 

 

Turning on Y25 will increase the value of D10 by 1. When the value of D10 reaches 10,000, it will 

increase the value of 100 by 1 and clear the data of D10 as 0. 

 

R Device (Index Register) 

- R device is used for index qualification (indirect addressing) of a device in sequence program. 

- CIMON PLC CPU offers a total of 16 index registers. 

- Index qualification uses one index register and is specified by 16 bit data  

 (-32767 – 32767 or 0000h – FFFFh) 

- Index registers are represented as ‘R00’ – ‘R15.’ 

Example) 

 

-1 is stored in R0.  

D100R0 is the Index Qualification. 

Data of D100R0 (=D99) is stored in D10. 
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Z Device (Word / Subroutine) 

- Z device is used for exchanging data with subroutine programs. 

- Every running scan program has two 64 words of Z memory area. (One for scan / one for subroutine) 

- Its own memory area (parameter) can be accessed with Z1000 to Z1063. 

- Subroutine’s memory can be accessed with Z0000 to Z0063. 

 

If there is some data to transfer to subroutine, just store them in ‘Z1000’ to ‘Z1063’ and next call the 

subroutine. Then, the called subroutine can read and process the data and store the result at the 

address of ‘Z0000’ to ‘Z0063’. 

At any time a sequence program can access two 64 words blocks of ‘Z’ memory. And the total size of 

physical ‘Z’ device is 1024 words that the reason maximum call level is restricted to 16. The 

relationship between physical memory and programming address of ‘Z’ device at different call level 

was explained more precisely in following drawing. 

 

Example) 

 

After inserting the value of D0 to Z1000 and the value of D1 to Z1001, a subroutine is called. 

In the subroutine, it transfers the value of Z0 to D100 and the value of Z1 to D101 and then ends. 

In other words, this is how the above scan program processes the data: 

D0 → Z1000 → Subroutine jump → Z0 → D100 

D1 → Z1001 → Subroutine jump → Z1 → D101 
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Q Device (Bit / Sequential Function Chart) 

- Q device is used only for the SFC program. 

- Descriptions and variables of the Q device are pre-registered. 

- Only PLCS (CM3) CPU series can utilize the Q device. 

- If used as a word type, Q device can be used according to the bit device’s word usage. 

 

3. CICON Screen Configuration 

 

1) Menu Bar 

2) Toolbar 

3) Project Window 

4) Message Window 

5) Work Window 

6) Variable Editor Window 

7) Toolbar Customize Feature 

8) Docking Feature 

9) Status Window Shortcuts 
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3.1 Menu Bar 

 

Menu names provided by the CICON software will be displayed. When you click the Menu Bar, 

the dropdown menu will be displayed and enable you to use various functions. 

 

3.2 Toolbar 

Frequently used menu icon buttons are displayed on the Toolbar. 

Basic      

Edit       

Search     

View      

Online     

Tool       

Window   
 

 

3.3 Project Window 

Project Window displays a current project and its related program, parameter and card properties. 
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3.4 Message Window 

The Message Window displays results of compilation, download and search in a list. To check the 

previous messages, scroll down the bar on the right side of the Message Window. 

 

Message: displays all the notifications executed in the CICON software.  

 

 

Build: displays results of compiling and linking with PLC program. 

 

 

Found 1/2: displays search results. 
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3.5 Work Window 

The Work Window displays several types of edit windows such as Edit Variable, Edit Ladder Diagram 

and Edit Parameter. Each Edit Window is used to edit program, parameter and configuration. 

 

 

3.6 Variable Editor Window 

The Variable Editor Window displays variables for each device area and is used to add, delete, edit and 

describe variables. 
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3.7 Toolbar Customize Feature 

The Toolbar Customize Feature allows a user to select which icons to be displayed on the Toolbar. 

 

 

3.8 Docking Feature 

The Docking Feature is used to situate each window based on a user’s preference in the CICON 

software. By clicking “Show Docking Sticker” in the CICON Configuration, the Docking Feature is 

enabled. 
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The Docking Feature (marked in red) will appear on the screen when you drag the header of any 

window (Project Window, Device Monitor Window, Message Window and Variable Editor Window). 

With the Docking Feature being activated, you can modify the location of each window by dragging 

your mouse.  

 

 

3.9 Status Window Shortcuts 

 
1) Alt + F6: a change of focus among Status Windows 

2) Alt + F7: displays Status Window Focus Movement Tool on the screen 

3) Ctrl + Tab: displays Program Focus Movement Tool on the screen 
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3.10 CICON Menu in detail 

 
3.10.1 FILE (F) 

Menu Note 

New Project Creates a new project. 

Open Project Opens the project that was already created. 

Open Project from PLC Opens the project from PLC. 

Import OPC UA Project 
File  

Imports OPC UA project file. 

Export OPC UA Project File Exports OPC UA project file. 

Close Project Closes the currently working project. 

Clone Project Copies the desired project. 

Recent Project Shows the list of projects that were recently edited and created. When 
you click the file, it will be executed. 

New Program Creates a new program. 

Open Program Opens the program that was already created. 

Close Program Closes the currently working program. 

Save Program Saves the currently working program. 

Save Program As Saves the currently working program with a different name and entity. 

Save All Saves all programs belonging to the currently working project. 

Project Properties Displays properties of currently working project. 

Program Properties Displays properties of currently working program. 

Program Properties 
Configuration 

Displays configuration for each program of the currently working 
project.  

Add a Program Adds the existing program to the selected project. 

Delete a Program Deletes the selected from the project. 

Restore Program Restores a program to the previous conditions by selecting the desired 
program and the different times it was saved. 

Import Single Program Imports a program from a different project and registers on the 
currently working project. 

Print Prints out the currently working program. 

Preview Shows the print preview screen. 

Print Setup Modifies the printer and its settings. 

Page Setup Adjusts margins of the printing page. 

Exit Ends the CICON software. 
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3.10.2 EDIT (E) 

Menu Note 

Undo Cancels the job that was made just before. 

Redo Cancels the undoing job that was made just before. 

Cut Copies the selected area in the clipboard first and deletes the selected 
area. 

Copy Copies the selected area in the clipboard. 

Paste Pastes the copied contents into the designated clipboard area. 

Delete Deletes the contents of the selected area. 

Select All Selects the entire program area. 

Insert Row Inserts an empty rung below the blue cursor. 

Insert Next Row Inserts an empty rung above the blur cursor. 

Delete Row Deletes the selected rung. 

Space Column Moves the selected contact to the right by one column. 

Arrange Rung Clears up unnecessary steps of rungs in the LD Editor. 

Device Description Adds a description underneath the selected device or an instruction. 

Program Line-Up Deletes empty or incomplete rungs in the program. 

Remove All Comments Clears all comments of the currently working program. 

 

3.10.3 SEARCH (S) 

Menu Note 

Find and Replace Finds and replaces the selected contents. 

Find Previous Searches for the contents located above the current position. 

Find Next Searches for the contents located below the current position. 

Find All Searches for the contents within the selected scan program and displays 
the result on the Message Window. 

Go to Step Moves to the designated step number. 

Go to Statement Moves to the designated comment or description. 

 

3.10.4 VIEW (V) 

Menu Note 

Toolbar Shows and hides the CICON Toolbar. 

Status Bar Shows and hides the CICON Status Bar. 

Project Window Shows and hides the Project Window. 

Variable Window Shows and hides the Variable Window. 
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Device Monitoring Shows and hides the Device Monitoring Window. 

Message Window Shows and hides the Message Window. 

IL Edit Toolbar Shows and hides the toolbar on the IL Edit Window. 

IL Edit Help Shows and hides the IL Edit Help Window. 

Variable Editor Toolbar Shows and hides the toolbar on the Variable Edit Window. 

Change LD Column 
Count 

Shortens or lengthens the length of the rung by selecting the number of 
the LD columns from 9 to 15. 

Change SFC Column 
Count 

Shortens or lengthens the length of the rung by selecting the number of 
the SFC columns from 12 to 32. 

Zoom In Zooms in the LD Edit Window. 

Zoom Out Zooms out the LD Edit Window. 

Variable Editor Controls displays of device, variable and description on the LD Edit 
Window.  

Show Grid Shows and hides the grid on the LD Edit Window. 

Language Selects the CICON display language between English and Korean. 

 

3.10.5 ONLINE (O) 

Menu Note 

Link+Download+Monitor Proceeds connecting with, downloading to and monitoring PLC. 

Connect Makes a PLC connection attempt. 

Disconnect Disconnects from PLC in the online state. 

PLC SCAN (Ethernet) Scans PLC for Ethernet IP Address. 

Download (PC  PLC) Downloads the compiled program from the CICON software to PLC. 

Upload (PLC  PC) Uploads the program that was downloaded to PLC. 

Compare/Check Program 
(PC PLC) 

Verifies whether the edited program matches the program 
downloaded to PLC. 

Firmware Upgrade Upgrades firmware for PLC-S, MPnA and XPnX only. 

SD Card Downloads to and uploads from SD card for PLC-S, MPnA and XPnX 
only.  

Module Config Export – for 
Simulator 

Exports the module configuration for simulator. 

Online-Edit Start/Cancel Starts or cancels modification while running PLC. 

Online-Edit Download Downloads the modified program while running PLC. 

Memory monitor Activates the Memory Monitor. 

Program Monitor Starts and stops program monitoring. 

Clear Memory Deletes the programs and parameters saved in the PLC RAM or clears 
all data from PLC.  
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Flash Memory Changes the modes of PLC operation between RAM and ROM, copies 
the RAM program to the ROM or deletes the ROM. 

Memory Download/Upload Downloads and saves device memory data as a back-up file. The back-
up file can also be uploaded to PLC. 

Change Mode Runs, stops, pauses PLC when the PLC mode switch is in the remote 
state. 

CPU Error Reset Resets status of CPU failures and reactivates self-detection of CPU. 

Enable/Disable Module Prevents I/O mounting/dismounting error of the specified slot. 

Enable/Disable Scan 
Program 

Controls enabling and disabling of a specific scan program. 

PLC Password Sets the connection password for PLC. 

Special Module Setup Sets configuration for each special module connected with PLC. 

Refresh Card Properties in 
Project Window 

Reads the information on the module mounted on PLC and displays it 
on the Project Window. 

PLC Status Checks the PLC CPU state and sets the time. 

 

3.10.6 DEBUG (D) 

Menu Note 

Enable Forced 
Input/Output 

Allows forced input and output. 

Forced Input/Output 
Setup 

Sets up configuration for forced input and output. 

Run Debugging/Continue Starts and continues debugging. 

Stop Debugging Stops debugging. 

Run and Scans Maintains operation for the designated scan area.  

Assign/Release Break 
Point 

Sets or clears the break point. 

Release All Break Points Clears all break point settings. 

 

3.10.7 TOOL 

Menu Note 

Compile Compiles the working file. 

Link Links the compiled file. 

Compile+Link Complies and links sequentially. 

Compile+All Link Compiles and links the entire project. 

Downloader Creates and exports a “.DWN” file that can be downloaded. 

IL-LD Conversion Converts the editing program to IL or LD. 
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Cross Reference Provides an overview of the use of addresses within the CICON user 
program. 

Bookmark Leaves and clears a bookmark. 

PLC Parameter Opens the PLC Parameter Setting Window. 

I/O Reservation Opens the I/O Reservation Setting Window. 

Position Module Opens the configuration and status windows for the Position Module. 

Variable Editor Opens the Variable Editor Window. 

Device Trend Opens Device Trend. 

Run PLC Simulator Monitors and controls ladder program without running the actual PLC. 

CICON Option Configures settings related with CICON operation. 

Connection Setup Configures communication settings for each different type of connection.  

 

3.10.8 WINDOW (W) 

Menu Note 

Close All Closes all the editing and working windows at once. 

Activate Inactive Menu Activate menu that was disabled during compiling or downloading. 

Cascade type Arranges the editing windows with a cascading layout. 

Tile type Arranges windows as horizontal and non-overlapping tiles. 

Arrange Icons Arranges icons at the bottom of the window. 

 

3.10.9 HELP (H) 

Menu Note 

Help Opens the help text on the CICON software. 

About Displays the version of the currently installed CICON software. 
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3.11 CICON Configuration 

 
3.11.1 General 

 

 

Location of Project Folder: Specifies the default folder for new project. When creating a new folder, 

the folder name cannot contain any of the following characters (\ / : * ? “ < >). 

Open the Last Project: Opens the most recent project automatically when starting the CICON 

software. 

Open the Last Programs: Opens the most recent program along with the project when starting the 

CICON software. 

Start without Showing Program: If this feature is activated, the last program will NOT be displayed 

automatically even when “Open the Last Program” has been clicked.  

Hide Variable Table: Hides the Variable Table when starting the CICON software. Using the shortcut 

key “F11,” you can easily hide and show the Variable Table. 

Hide Update News: Hides “Update News” when starting the CICON software. 
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Enable Upgrade Notice: Displays “Update News” when starting the CICON software. 

Do Not Check CICON Version: If this feature is activated, a user will NOT be notified on whether the 

installed CICON software is up to date with the latest version available.   

Compile before Download: If the downloading program is modified, it will be automatically 

compiled. 

Do Not Download Variables: Variables are excluded at the time of compilation. The Variable Table 

will NOT be saved in PLC. When the downloaded PLC program is uploaded, the Variable Table will 

NOT be uploaded. This feature is useful for program security. 

Enable Auto Save: Automatically saves the project at the specified time interval (1-100 min). This 

feature activates only when there is a change to the contents of a program. 

Compare & Verify after Download Project: Compares program files in the CICON software one after 

another with that of PLC and notify the user of the differences between them. 

Hide Online Status Bar: Hides Online Status Bar which otherwise displays CPU version, current mode 

and connection status of PLC with the CICON software. It also lets you either disable and enable 

forced I/O. 

Hide Splash (CICON Logo at the start of the program): Hides the CICON logo splash when starting 

the CICON software. 
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3.11.2 LD Editor 

 

Return arrow after Insert Symbol: After entering the LD symbol, the mouse cursor returns to “Select 

Mode” otherwise previously selected LD symbol will stay with the mouse cursor. 

Display Description Windows after Insert Command: Whenever a contact, coil or instruction is 

inserted in the ladder diagram, a description window follows and enables a user to describe each entity. 

Disable Download Description: Compile the programs without descriptions. When a user uploads the 

programs, the descriptions will be displayed in empty lines. This feature is useful for program security. 

Do not display “Duplicate coil” warning: Despite a duplicate coil, a warning message will not pop up. 

Duplicate Coil Occur, Downloading and Online-Edit is not Allowed: When a duplicate coil is found in 

the ladder diagram, the program will not be downloaded to PLC nor Online-Edit is allowed.  

Disable Delete empty: This feature enables a user to have empty rungs in the ladder diagram. 

Use the Old style LD editor (Restart): A user can write and edit ladder diagram in the old style. The 

CICON software must be restarted. 

Display Device List at Insert Contact: Whenever a contact is inserted, the Device List Window is 

followed and enables a user to select a device among the list. 
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Display Variable List at Insert Contact: Whenever a contact is inserted, the Variable List Window is 

followed and enables a user to select a variable among the list. 

  

Do not insert “END” in NEW LD Program: The instruction “END” will not automatically be inserted 

into a new LD program whenever it is created. 

Show LD Editor Toolbar: The LD Editor Toolbar is activated and shown within the Ladder Diagram 

Editor Window (also called Work Window). 

Use Zoom Function:  This feature enables a user to zoom in and out the ladder diagram. 

Hide program title (Print): The ladder diagram will be printed without project and program titles. 

Font Setting: A user can select a LD Editor font provided by Windows System. However, some fonts 

may cause display problems and may not represent variable names or instructions clearly. 

Background Color Setting: Background color of ladder diagram can be selected respectively for 

Normal Mode and Online Edit Mode.   

Font Color Setting: Font color can be selected for variable names and descriptions. 



 

38 

 

CICON USER MANUAL 

3.11.3 HOT KEY 

 

Shortcut keys can be customized and registered for all the menu and functions. Select a menu that 

you wish to create a shortcut for and then type in any desired combination of keys. Click the [OK] 

button. 

 

3.11.4 THEME 

A display theme can be selected based on a user’s preference. Unless specifically selected, default 

setting will be applied automatically. 

Show Docking Sticker: The Docking Feature is used to situate each window based on a user’s 

preference in the CICON software. By clicking “Show Docking Sticker” in the CICON Configuration, 

the Docking Feature is enabled. Instructions on how to use it are found in 3.8 Docking Feature. 
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4. Develop Application 

 
4.1 Create a Project 

In order to develop logic program, project file must be created at first. 

1) Start CICON software. 

2) Click File → New Project or click  
Choose the PLC CPU type and then click Next. 

 

 ● XPnA: XP1A, XP1R, XP2A, XP3A 

● XPnB: XP1B, XP2B, XP3B 

● CP: CP3A, CP3B, CP3U, CP3P, CP4A, CP4B, CP4C, CP4D, CP4U 

● PLCS: SP32, SP16, Hybrid Xpanel (HP-07CD) 

● PLCS Block: SB16 
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3) Project Properties dialog box appears. 

 

● Default path: it is where project file will be stored. 

● Project Path: It is used to change the path where project file will be stored. 

● Set as default path: click this if you want to make current path as default path. 

Another way to change Default folder, click Tool → CICON Options. 

In General tab, click Locations and choose the folder where project file will be saved.  

● CPU Type: It is used to go back to CPU type dialog box. 

● Series No. : click this to change CPU series. 

In case of Hybrid Xpanel, Hybrid XPanel appears on the Project Properties. 

Click the box to choose Hybrid Xpanel. 

● Name: The default project name is current date and time. Rename project name. 

“Prj+month+date_current hour+minute” 

Example) Prj0306_1316 → March 6th. 13:16PM 

● Developer: The developer name is the same as the name of your PC(Administrator). 

● Description: Write description of Project if necessary. 

● Password: Click Password Setup in order to lock project with password. 

This password will be used when you open this project file. 

If you forget the password, your project cannot open. 

● Connections: It is used to choose the type of project download. 
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You can choose Serial port, Dial-up Modem Leased Line Modem, Ethernet, PLC Simulator, and USB 

port. Click OK to save all data and to open new project. 

 

4.2 Register a New Program 

1) Click File → New Program or click  

Or Right-click Program and click New Program. 

 

2) Type program name and select ID number. 

● ID: The lowest ID number runs first. 

● Online Edit Buffer: It is extra steps for online edit. Default is different with CPU types.  

If this number of steps is reduced when you edit steps online.  

3) Choose a Scan program and then click OK. 
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4.3 Enter Ladder Logic 

 

LD Edit ToolBar 

To enter ladder logic, you have the following options: 

Erase: Delete logic elements or Instructions 

Normally Open Contact: If the bit is On(1) then the Coil turns the On(1) 

Normally Closed Contact: If the bit is Off(0) then the Coil turns the On(1) 

Coil: An output instruction that controls one bit of data. 

Vertical Line: Add vertical line (It connects branch to branch) 

Delete Vertical Line: Delete Vertical Line 

 

1) Add a Rung: Click Edit → Insert Row or press Ctrl+L, Rung is added at the below of Blue cursor. 

Click Edit → Insert Next Row or press Ctrl+Enter, Rung is added at the above of Blue cursor. 
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2) Click  (Positive Transition-Sensing Contact) or press F7 and then type X0000. 

 

3) If you want to register variable description with name, use Variable Editor Window. 

 
 

4) Click (Coil) or press F9 and type M0000. 
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5) Click Edit → Insert Row or press Ctrl+L to add Rung and click (Normally Open 

Contact) or press F5 and then type Y0010. 

 

6) Click    (Normally Closed Contact) or press F6 and type M0000. 

 

7) Click (Coil) or press F9 and type Y0010. 

 

 

8) Click Edit → Insert Row or press Ctrl+L. 

 

Click and type Y0010. 

 

Click and type M0000 and then press Ctrl+↑ to add vertical line. 

 

Now this example shows a parallel branch with two levels. 

9) Click PEND Rung and press Ctrl+L to add a Rung. 

 

Click  (Application Instruction) or press F10 and then type END to finish developing  

 

ladder logic. 
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10) Click File → Save Program or click  

 

 

If program is saved completely, red vertical line disappears. 

 

TIP 

Click Tool → CICON Options and CICON Configuration pops up. 

Click LD Editor Tab to change the LD Editor setting. 
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If you choose Show LD Editor Toolbar and do not choose Do not insert “END” in New LD Program, a 

new scan program appears as below picture. 
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4.4 Copy a Project 

You can copy a project and paste to other folder with different name. 

Click File → Clone Project. 

 

Type Project name and choose the folder you want to save in. 

 

4.5 Find and Replace 

It is used to search device address or comments in ladder Logic program. 

1) Click the Rung where you want to start finding. 
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2) Click Search and then click Find and Replace. 

Write device or comments that you want to find out. 

 

● Device: It finds out only device address. 

● String: It finds out only Comments. (Capital / Small letter) 

If you click   there are more detailed options as follows. 

 

You can choose the direction and data type for Device search. 

3) Click Find Next. 

If it finds out a device or a comment, the cursor will move to that device or comment. 
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4) If you want to replace a device or comment to others, click Replace tab. 

 

Example) Change M00 device to M01 

Type M00 at Find what and M01 at Replace with. 

Click Replace All or Replace 

 

5) Pop-up message appear as follows and device M00 is replaced to M01. 
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6) If you click, there are more detailed options as follows. 
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● Range (Step): It finds and replaces in the set range. (Device only) 

● Replace with range: It replaces device from starting device address. 

W: Word, B: Bit 

 

 

■ Icon for Find and Replace 

 

In order to use Search icon, click View → Tool Bar and choose Search. 

Type a device or comment and click icon for quick search. 

 

4.6 Compile and Link 

Before you download a project to PLC, ladder logic program must be compiled. 

1) Open a project that you want to download. 

2) Click Tool and choose Compile All+Link. 

3) The result appears on the Message window. 

 

 

4.7 Connection Setup for Downloading a Project to the PLC 

Before you download a project from your computer to the PLC, Computer and PLC must be connected 

through one of communication in Connection Setup. 

1) Open the CICON project that you want to download. 

2) Click Tool and then Connection Setup. 

3) From the Type pull-down menu, choose one of communication. 

There are 6 types of communications as follows. 
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■ Serial Port  

  

● Port : Choose the port number of computer which Serial cable is connected to PLC. 

● Baud rate : Choose default 38400bps if computer is connected to loader port of CPU module. 

If computer is connected to Serial communication module (CM1-SC02A, SC01A, SC01B, SC02C, CM3-

SP02ERS, SP02ERR, or etc.), it must be matched with Baud rate of Serial module. 

 CPU module (Loader port) Serial communication module 

Default Baud rate 38400bps 300 – 38400bps 

 

● RTS/CTS : It is used when computer is connected to PLC through RS485 type. 

● Tx Delay : it is used when computer is connected to PLC through USB to Serial converter. 

From the Tx Delay pull-down menu, choose the one to protect heavy frame loading. 
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■ Ethernet 

 

Type IP Address or Domain name of Ethernet module or CM3 CPU module. 

● Scanning PLC : To find out IP address of PLC which is already connected to your computer, click 

Scanning PLC. 

 

Click Scan to search IP address and choose the one you want to connect. 
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■ PLC Simulator 

 

To simulate ladder logic program without PLC modules, choose PLC Simulator. 

You can also connect PLC Simulator to XPANEL or UltimateAccess(SCADA software). 

For more information of PLC Simulator setting, please refer to PLC Simulator chapter. 

 

■ USB port 

 

Choose USB port if your computer is connected to PLC through USB cable. 
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● If your computer connects PLC through USB port first time, the computer may not connect to PLC 

because USB driver is not installed in the computer. 

For USB driver installation, please click here. 

 

4.8 Download a Project to the PLC 
1) Open a project you want to download. 

2) Click Online and choose Link+Download+Monitor or Download(PC→PLC) 

 

● If you want to save memory of CPU, uncheck Comment(Program) and Variable Table. 

3) Click OK. 

 

4) When download completes, pop-up message appears as follows. 
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Open a project you want to download. 

5) Click Online and choose Link+Download+Monitor or Download(PC→PLC) 

 

● If you want to save memory of CPU, uncheck Comment(Program) and Variable Table. 

6) Click OK. 

 

7) When download completes, pop-up message appears as follows. 
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4.9 Monitor a program 

To monitor a project that is executing in a PLC, CICON(computer) must be connected to PLC. 

There are three way to operate program monitor. 

● Click Online and choose Connect. 

● Click Online and choose Link+Download+Monitor, Monitor runs automatically when downloading 

completes. 

● Click Online → Program Monitor and choose Start Program Monitor or click 

 

 

If contact is ON, blue mark appears on the contact. 

To change the device value, press Shift + double click the contact or press Shift + Enter. 

■ Memory Monitor 

To monitor device values, click Online and choose Memory Monitor or click       . 
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If you change the value at the ladder logic program, Memory Monitor shows the value. 

 

4.10 Create a Variable Editor for Device 

 
1) Click View and choose Variable Window or press F11. 

2) Variable Editor appears. 

 

Device address is Bit or Word type. 

● Bit Device : X, Y, M, L, K, T, C, S 

● Word Device : X, Y, M, L, K, D 
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3) Click Reg. Var and type variable description or name. 

4) You can also copy the variable description and name from Excel and paste to Variable Editor. 

5) Write variable description and name on the Excel and drag cells that you want to copy and press 

Ctrl + C. 

 

6) Click the Split or All Variable and select device and then click the Description cell of address 

you want to paste and press Ctrl + V. 
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7) If you click Split, you can see Variable description and name by Device. 

 

8) Click Save. 

If Variable is saved completely, the message pops up as below. 

 

If you don’t save the Variable table and close CICON, all variable that you add or edit will be removed. 

Also, when you print or export Variable, Variable table must be saved. 
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[TIP] Consecutive number can be created automatically. 

1) Type description or Variable name at the first cell. (Last character must be number) 

 

2) Select the first cell and press Shift and drag mouse down. 
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■ Variable Table Expanded Function 

If you click More, Variable Table Expanded Function dialog box pops up as below. 

 

● Transparency : Adjust dialog box transparent. 

● Search : It is used to search device address, variable description, variable name or type. 

Type what you want to find out and click Find. 

● Sort : It is used to show variable by data type. 

● Print / CSV (Export/Import) : It is used to import and export variable table. 

- Export : You can export Variable table to CSV file or print it out. 

(You can also export Variable table in another way. Click Tool → Variable and choose Export. It is 

saved as PLCV file.) 

1) If you click Export, Variable Output dialog box appears. 
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2) Choose the Output Type and variable that you want to export and click Export. 

3) Select the folder that you want to save and click Save. 

4) Your variable table is saved in CSV file as follows. 

 

 

- Import : You can open CSV file in Variable Editor.  

(You can also import PLCV file in another way. Click Tool → Variable and choose Import.) 

The variable table format must be as follows. 

 

■ Format follows these conventions 

The first row (No., Device, Description, Variable and Type) can be eliminated. 
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Variable name cannot contain special character, space or same variable name. 

Only Bit and Word are available. 

 

1) Click Import and select CSV file that you want to open. 

2) If variable name already exists in Variable Editor, you can select options. 

 

3) If CSV file opens successfully, below message appears. 

 

You can also check all history at the Message Window. 
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4.11 Device Memory download and upload 

It is used to download device memory value from CICON to connected CPU module or upload 

device memory value from CPU module to CICON. 

 

Upload device memory 

 

Click Online → Memory Download/Upload and choose Upload device memory (CPU → File). 

The Upload device memory window appears. 

 

● File : Click Path to select the folder that you want to save uploaded device memory. 

(Default folder is Project folder) 

● Save : Choose the device and edit address and then click Save. 

● Default : Latch device and address are default. 

● Clear All : Delete all device and address. 
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● Max. Set : Maximum address will be set for all devices. 

● Editor : You can monitor or edit the value of device memory. 

(It is activated after uploading is completed.) 

 

● Upload : The values of selected device and address are uploaded from CPU module to 

computer. 

■ The range of starting and finishing address depends on CPU type. 
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Download device memory 

 

Click Online → Memory Download/Upload and choose Download device memory (File → CPU). 

The Download device memory window appears. 

 

The setting configuration is the same with Upload device memory window. 

■ T, S, Z, F, C and R cannot be downloaded. 

 

4.12 Upload Program from PLC to computer 

It is used to import Programs from connected CPU module to computer. 

1) Click Online and select Connect. 

2) When CICON connects to CPU module, click Online and select Upload (PLC → PC). 
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If you want to backup opened project, click Yes. 

3) Type project name and choose the folder that you want to back up and then click OK. 

 

4) If backup is completed, Upload window appears. 

 

● Parameter : If you choose it, the parameter data of CPU is uploaded. 

● Program Block : If you choose it, the program and variable table are uploaded. 

5) Click OK to upload. 

6) Uploading is completed, below message appears. 
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You can find out uploaded contents at the Message Window. 

 

 

4.13 Edit Logic while Online 

Edit your Ladder logic while the controller continues to control your machine or process. 

 

1) Click Online and choose Edit Start/Cancel or click   

 

The background color of LD Editor Window is changed. 

(To change color, click Tool → CICON Options and click LD Editor tap and select color of 

Online Edit mode.) 
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■ If more than 64 steps of ladder logic are edited online, Online Editor will not work. 

2) Click rung or command that you want to edit. 

3) Click Online and choose Online-Edit Download or click to download. 

 

4.14 Compare the downloaded program 

It is possible to compare downloaded program in PLC with program in CICON. 

Click Online and choose Compare/Check Program (PC ↔ PLC) or click. 

 

● In case of matched program 

 

 

● In case of unmatched program 
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4.15 Set the Password for PLC and Program 

CICON provides password security for both program and PLC to protect the PLC Program, 

Configuration access from unauthorized person. 

1) Set the Program Password 

You can set the Program Password when you create new project or edit project properties. 

To open the Program file, you need to know the password. 

However once this program is downloaded to PLC, you can upload it to CICON without password. 

In order to lock the uploading program from PLC to CICON, choose Prohibit Program 

Upload(PLC→PC) at the PLC Parameter as below. 
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Click File → project Properties 

 

Whenever you try to open the program, CICON asks you for password. 

2) Set the PLC Password 

It is used to protect connection to PLC CPU module. 

(If you lose the password, it is impossible to connect this PLC again.) 

To set up the PLC Password, CICON must connect to PLC first. 

Click Online → PLC Password. 

 

If there is password already, type current password at Old. 

If there is no password, just leave blank at Old and type new password at New. 

Whenever you try to connect PLC CPU module, CICON asks you password. 
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4.16 Cross Reference 

Cross Reference shows all used device information on Report window. 

Click Tool and choose Cross Reference. 

If you choose Detailed usage at the Report Type, you can see all devices information as below 

picture. 

 

From the Report Type pull-down menu, you can choose 6 different report type. 

• Detailed usage : Display all information of devices 

• Usage overview : Display value of used device address 

• Usage overview with comments : Display Device Contact, Coil, Variable name and Description. 

• Usage overview including unused : Display value of used device address 

• Usage overview with comments including unused : Display Device Contact, Coil, Variable name and 

Description. 

• Duplicate usage : Display duplicated device address with Program, Variable name and Description. 

 

If you click Device, Program name, Step or Instruction, LD Editor will show you where you click. 

The blue box point out where you have clicked on the Cross Reference. 
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4.17 Bookmark 

Bookmarks are links to Rung that make it easy to get back to Rung you saved. 

To save Bookmark, click the Rung that you want to save and click Tool → Bookmark and choose 

Save/Delete Bookmark or click      . 

The Bookmark      appears next to Rung number. 
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If you delete a Bookmark, click Tool → Bookmark and choose Save/Delete Bookmark . 

 

You can also move previous bookmark or next bookmark with icon  

 

4.18 Search PLC by Ethernet Scan 

If your network is standalone network, CICON can search PLCs which are connected the network by 

Ethernet. 

Click Online and choose PLC SCAN(Ethernet). 

 

To search a PLC, click Scan. 
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All Ethernet IP addresses which are connected to the network display on the PLC SCAN window. 

If PLC has the same project file with your CICON, red highlight is remarked. 

If PLC is locked with password, #secured displays at the Project. 

In order to connect locked PLC, double click IP address and type password. 

 

You can also open PLC SCAN at the Communication Setup. 

Click Tool and choose Connection Setup. 

From the Type pull-down menu, choose Ethernet. 
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Click Scanning PLC. 

 

4.19 Reset CPU Error 

It is used to reset CPU error.  

(Only Remote mode supports this function.) 

 

If error occurs, PLC Status shows Major Fault. (Click Online → PLC Status) 
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Or Online Status Bar displays error. 

 

In order to reset error, CPU module must be Remote mode. 

(Turn switch on CPU module as Stop mode → Remote mode) 

Click Online and choose CPU Error Reset. 
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PLC Status changes to Normal. 

 

Online Status Bar also display OK signal. 
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▶ Notice  

CPU Error Reset can be supported below firmware version. 

Module Firmware version 

CM1-XPxxx 3.09 or higher 

CM1-CPxxx 3.02 or higher 

CM1-EPxxx 3.04 or higher 

CM3-SPxx ALL 

CM3-SBxx ALL 

CM2-BP32xx 1.25 or higher 

CM2-BP16xx 1.14 or higher 

 

5. PLC Parameter and Reserved IO 

 
5.1 PLC Parameter configuration 

According to CPU type, the configuration menu for PLC parameter is different. 
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▶ XPnA CPU and CP3 CPU Type 

All CIMON CPU Type has below Parameter menu as standard. 

Basic, Latch Area Setup, Interrupt and CPU Error manipulation are in PLC Parameter. 
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▶ MP CPU and CP4 CPU Type 

Communication Port menu is included. 

User can set RS232, RS422 and RS485 parameter for CP4C, CP4D and CP4U CPU type. 
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▶ XPnB CPU Type 

Modbus menu is included and it can be used for XPnB and CM3 CPU type. 
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▶ CM3 CPU type 

Channel 1, Channel 2, Input Setting, Modbus and Ethernet menu are included. 
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5.1.1 Basic 

 

 

5.1.1.1 Action 

• Override the instruction error : CPU keeps running even if there is instruction error in scan program. 

• Allow DO while debugging : Use output while debugging is running. (Default is “Not used”) 

*It does not support CM3 CPU Type. 

• Asynchronous scan(Timer) : Scan does not match Timer. 

 

5.1.1.2 Timer 

• Set time unit for Timer instruction. 

If Timer is configured as above, T0000~T0127 device has 100ms time unit and T0128~T0511 has 

10ms time unit. If 100ms range is 0~-1, all Timer devices become 10ms. 
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According to CPU type, Timer device range is different. 

CPU Type Timer Range 

XP CPU T0000 ~ T4095 

CP CPU T0000 ~ T1023 

CM3 CPU T0000 ~ T0511 

CM2 CPU T0000 ~ T0255 

 

5.1.1.3 Communication 

• Permit data writing from remote 

User can access CPU memory and change the device value by remote access (CICON). 

• Permit CPU mode change from remote 

User can change the CPU mode (RUN, STOP, PAUSE) by remote access (CICON). 

• Enable PLC-Link auto-swap (CPU: XP1R) 

In Redundancy system, if Primary is failed, Secondary will run automatically. 

*It is only for XP1R type. 

 

5.1.1.4 Watch Dog Timer 

You can set 10ms up to 60000ms to prevent malfunction of scan program. 

Designed WDT is longer than scan time, CPU will be reset automatically. 

 

5.1.1.5 Upload 

• Prohibit Program Upload (PLC → PC) 

Uploading project file from PLC to CICON is not possible. 

If you click Online → Upload(PLC → PC) after downloading program to PLC with this function, Error 

message will pop up as below. 
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5.1.1.6 Hot Restart 

If power is ON in designed time, Hot Start Initialization program will run first before scan program. 

*If CPU does not support RTC, it does not work. 

(CM1-CP3A, CM1-CP4A, CM3-SB16MDT and CM3-SB16MDTV do not support Hot Restart) 

 

5.1.1.7 Expansion 

If you want to use Expansion Base, choose Base number. 

*CP3 and XP CPU type support Expansion Base. 

 

5.1.2 Latch Area Setup 

 

It is used to save the final value in designed device address after CPU power off. 

If you turn CPU on, the final value is still in Latch device. 

The Latch device range is different according to CPU Type. 

*K device supports Latch as standard. 
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5.1.3 Interrupt 

It is used to make sequence of Periodical Interrupt program. 

 

Periodical Interrupt program must be in Program folder. 

 

• Modify Interrupt Program 
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If you click Modify Interrupt Program, you can set ID, Priority and period of Interrupt. 

- Priority : Number0 is the most priority. 

Period(msec) range : 10ms ~ 655,350ms 

*Interrupt instruction 

Instruction LD Description 

EI  Enable Interrupt 

DI  Enable Interrupt 

GEI  Enable Interrupt 

GDI  Enable Interrupt 

IRET  End Interrupt 

For more details, please refer to Instruction manual. 
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5.1.4 CPU Error Manipulation 

 

User can choose the operating condition of CPU when error occurs on a module. 

• The features in the red box do not support CM3 CPU type. 
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5.1.5 Communication Port 

 

User can set RS232, RS422 and RS485 parameter for CP4C, CP4D and CP4U CPU type. 

• Type 

- Null/RS-422  

1) CM1-CP4C, CM2-BP32MDxx-R : RS232C without modem 

*CM1-CP4C should use Null/RS-422. 

2) CM1-CP4D, CP4U, CM2-BP32MDxx-S : RS422 

- Modem / RS-485 

1) CM1-CP4C, CM2-BP32MDxx-R : RS232C with Modem 

2) CM1-CP4D, CP4U, CM2-BP32MDxx-S : RS485 

• Station No. 

You can set up from 0 to 31. 

• Communication Parameters 

This parameter must be the same with connected device. 
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5.1.6 Input Setting 

 

*Input Setting is used with CM3 CPU type. 

• Pulse Input Catch  

If you want to use HSC, choose the address. 

• Digital Input Filter 

The Digital Input Filter is a feature that eliminates noise from input signals. This is useful when on-

site condition is noisy or pulse width is an important factor. By controlling the Digital Input Filter, it 

can increase the reliability on input pulse. If Input signal is shorter than the pre-defined Digital Input 

Filter time (value), this signal is recognized as invalid signal and ignored by module. Digital Input 

Filter also applies to noisy or chattering pulse. 

The selected address will run by User Input Filter Value. 

The unselected address will run by Standard Input Filter Value. 

*The minimum Input Filter value(Time) is 1ms. 
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5.1.7 Modbus 

 

*Modbus Slave is used with CM3 CPU type. 

Choose the starting address for each type. 
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5.1.8 Ethernet 

 

• IP Setting : Type IP address if Ethernet port is used. 

• Option : If you choose DHCP, IP address is assigned automatically. 

• CICON Relay Use (Programming Bridge) : When multiple PLC-S are connected over RS232C or 

RS485(N:N), CICON can provide a communication bridge channel between PLC-S. 

•DDNS Setting : DDNS setting is used to make a connection between PLC and CIMON SCADA 

especially when dynamic IP address is assigned to PLC. After setting DDNS Address and port, Site 

Name (ID) and DDNS Connection Retry must be set up. 

 

5.2 Reserved I/O 

Reserved I/O let you organize I/O points to match your modules which will be installed in Base. 

It is easier to detect wrong module installation and to replace module without I/O change. 

• The Reserved I/O supports only CM1 series. 
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1) Click Local : Detects Automatically. 

 

2) From the Base Type pull-down menu, choose the Base number. 
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3) Click the module and choose I/O type and points. 

 

- Occupy 01 : I/O 16points 

- Occupy 02 : I/O 32points 

 

4) Click Ok. 

You can find out I/O point for each slot you have just made. 

 

 

 

5) In order to reserve I/O points for expansion Base, click Enable and choose the number of 

expansion base at the PLC Parameter. 
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6) Double-click Reserved IO and click Expansion#01 tab. 

Choose Base type and write starting I/O address. 

The starting I/O address must be different with other expansion base or local. 
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7) You can also use I/O SCAN to find out slot information automatically. 

8) Click the module and choose I/O type and points. 

If module is not Digital I/O module, choose the Function Module. 

9) Click Online → Download then you can find out expansion I/O address starts from 200. 
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■How to read I/O points 

 

I/O address :0000~0100 

Slot No.0 : 16points, Occupied 1  

Slot No.1 : 16points, Occupied 1 

Slot No.2 : 16points, Occupied 1 

Slot No.3 : 16points, Occupied 1 

Slot No.4 : 16points, Occupied 1 

Slot No.5 : 16points, Occupied 1 

Slot No.6 : 64points, Occupied 4 

Slot No.7 : 16points, Occupied 1 

 

If Local base use 0000~0100, Expansion base needs to use from 0110. 

 

6. Scan Program 

SCAN PROGRAM OVERVIEW 

Scan Program: Program that processes the regularly repeated signal for every scan. 

Subroutine Program: Program composed of sub-routines that are called by “ECALL” command in the 

scan program.  

Initialization Program (Cold): Program executed when the power is supplied or mode of the PLC is 

switched to Run Mode. It configures the initial data and initializes the peripheral or special module 
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required to execute a scan program. 

Initialization Program (Hot): If the power fails temporarily within the setting time and the Hot 

Restart function is enabled in the PLC Parameter, this program is executed to keep previous values 

before the power failure and to successively execute a scan program. 

 Periodic Interrupt Program: Program executed at the specified intervals. 

 

6.1 Scan Program 

The Scan Program processes the regularly repeated signal for every scan. 

Select File → New Program menu to create a new scan program. 

 

Scan Program Properties 

1) Program Name: Displays the name of the program. 

2) Program ID: Decides the priority of program execution. Program is executed from ID with 
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the lowest number. 

3) Online Edit Buffer: Free space is reserved for the modification function while the program is 

running. If you keep editing online without downloading the program to PLC, the free space 

is reduced. Therefore, it is recommended that you secure the free space by reconfiguring 

the size of memory specified for downloading. 

 

6.2 Subroutine Program 

 

The Subroutine Program is a collection of programs that are called by the “ECALL” command in the 

scan program. The scan program calls SBRT n ~ RET commands in the Subroutine Program according 

to the “ECALL” command.  

For the “ECALL” command, a user enters Subroutine Program ID and its number. The result value of 

an instruction (Coil instruction, etc.) operating in the Subroutine Program is processed only when the 

Subroutine Program is called. 
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6.3 Cold Start Initialization Program 
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The Cold Start Initialization Program is executed when the power is supplied or CPU mode is 

switched from STOP to RUN mode. The Scan Program is executed after the Cold Start Initialization 

Program is complete. The Cold Start sets the initial data or initializes the peripheral and special 

module to run the Scan Program. 

 

You must use the “INITEND” command to end the initialization program. 
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6.4 Hot Start Initialization Program 

[Menu] → [Tool] → [PLC Parameter] or [Project Window] → [Parameter] → [PLC Parameter].
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1) [Menu] → [Tool] → [PLC Parameter] or [Project Window] → [Parameter] → [PLC Parameter] 

 

 

2) Enable the Hot Restart function in the PLC Parameter Window and set the time. This 

function will be executed only if the temporary power failure occurs within the setting time. 
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If the power fails temporarily within the setting time and the Hot Restart function is enabled in the 

PLC Parameter, the Hot Start Initialization Program is executed to keep previous values before the 

power failure and to successively execute a scan program. You must use the “INITEND” command to 

end the initialization program. 
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6.5 Periodic Interrupt Program 

The Periodic Interrupt Program is executed at intervals specified by Interrupt Period. 

 

How to Configure the Interrupt Program: 

1) Specify the Interrupt ID from 0 to 15. The ID number cannot be duplicated. 

2) Free space is reserved for the modification function while the program is running. If you 

keep editing online without downloading the program to PLC, the free space is reduced. 

Therefore, it is recommended that you secure the free space by reconfiguring the size of 

memory specified for downloading. 

3) The program with the lowest Interrupt ID gets a higher priority and will be executed first. 
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4) Enter the Interrupt Period that will execute the program by the specified intervals. 

5) If you want to run the Interrupt Program, use the “GEI” command to enable the usage of the 

program. Then, execute the program using the “EI” command. 

 

* For XPnB CUP type, Interrupt Program is executed automatically if it was registered previously. If 

Interrupt feature is disabled by using command “DI” on XPnB CPU type, then command “GEI” must 

be used to enable the Interrupt feature again. For all CPU types except XPnB, these two commands 

“GEI” and “EI” are used to enable and execute an Interrupt Program. 

Program Operating Principle: 
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The Initialization Program operates only during the early stage of PLC operation whereas the Scan 

Program operates repeatedly as long as the PLC is running. The Subroutine Program is executed only 

when it is called out by the “ECALL” command during the Scan Program. 
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7. Communication Program 

 
7.1 Serial Protocol 

The Serial Protocol program enables the user to manually define the communication frame of the 

serial communication module. 

Registering the Serial Protocol program 

Select [File] → [New Program] → [Serial Protocol] menu. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 

 

 



 

111 

 

CICON USER MANUAL 

Writing the Serial Protocol program 

Example of writing a program: The sample program reads 5 words from %MW100 of Glofa PLC and 

saves it in 5 words from D00100 of CIMON PLC. Communication is established using the channel #1 

(RS232) of the serial communication module, which is mounted in local base, slot #0. 

 

 Base: Local (Module mounted base) 

 Slot: Slot 0 (Module mounted slot) 

 CH: Ch1 (Channel to use: Ch1 (RS232), Ch2 (RS422/485)) 

 Result: M0000 (Specifying the device to save the communication result) 

 

 Add: Defines and adds new frame. 

 Edit: Edits the registered frame. 

 Delete: Deletes the registered frame. 

 Up: Moves up the registered frame by one space. 

 Down: Moves down the registered frame by one space. 

 Online Edit: Saves and applies the edited details to PLC when it is online. 

 Save: Saves the modified details. 

 

To move the frame position, Cut (Ctrl+X), move position and paste it (Ctrl+V). 

When you click the [Add] button, the Frame Setup window will appear as shown below. 
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[Frame Setup Items] 

 Frame: Name to differentiate the frame. 

 TX/RX: Sets the communication direction – sending or receiving. 

 Period: Sending frames will be automatically sent at the specified interval. 

 Rx Frame After Tx/ Tx Frame by Rx: Specifies the frame that corresponds to the response. 

 

[Segment Configuration Functions] 

 Add: Defines and adds a new segment. 

 Edit: Edits the registered segment details. 

 Delete: Deletes the selected segment. 

 Move Up: Moves the selected segment upward. 

 Move Down: Moves the selected segment downward. 
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1) Defining a receiving frame (RX frame of the continuous read command for the direct variable) 

It defines the frame contents to interpret the response frame for the continuous read 

requesting frame of the Glofa PLC’s direct variable. 

* Frame Setup: Select “Memory Link” or “Ignore” for [Segment] and configure 255 for [Length]. 

i. Defining a segment (header): Sets the header of the protocol. 

The header for the ACK response frame is ACK (06H) and should be set as shown below. 

  

ii. Defining a segment (station number): Sets the station number area for the protocol. 

Enter the station number of the counterpart (LG Glofa). The station number is “01” (1) 

and should be set as shown below. 
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iii. Defining a segment (command + command type): Continuous read command for the 

direct variable + command type rSB (r + SB) should be set as shown below. 

 

 

iv. Defining a segment (number of blocks + number of data): The number of block is 1 and 

the number of data is 10 (= 5Word * 2, 0AH). It should be set (01+0A) as shown below. 
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v. Defining a segment (data): Set to save 5 word data received from Glofa PLC in 5 words 

from D00100 of CIMON PLC. To display 5 word data as an ASCII code, 20 bytes (= 5 

words * 4 characters) are needed. 

 
 

vi. Defining a segment (tail): The tail of the ACK frame is ETX (03H) as shown below. 

 
 

 

vii. Defining a segment (BCC): BCC is the ASCII converted value of the lowest 1 byte out of 

the ASCII value that adds from the header to the tail. Configure as 2 byte for length, 0 ~ 

5 for segment range, SUM for check type and hexadecimal for ASCII data conversion. 
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2) Completing a receiving frame definition: (RX frame for the continuous read command of 

the direct variable). The communication direction is the receiving frame as shown below. 
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3) Defining a sending frame: (TX frame for the continuous read command of the direct variable) 

It defines the request frame of the continuous read command for the direct variable. 

 

i. Defining a segment (header): The header of the request frame is ENQ(05H) as shown 

below. 

 
 

ii. Defining a segment (station number): Set the station number as “01” (1). 

(See the contents in the “RX frame of the continuous read command for the direct 

variable” section.) 

 
 

iii. Defining a segment (command + command type): Set continuous read command for 

the direct variable + command type as “rSB.” (See the contents in the “RX frame of the 

continuous read command for the direct variable” section.) 
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iv. Defining a segment (variable length + variable name + number of data): Set the 

variable length as 6 bytes (06H), direct variable as “%MW100,” and the number of data 

as 5 words (05H) as shown below. (06 + %MW100 + 05) 
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v. Defining a segment (tail): The tail of the request frame is EOT (04H) as shown below. 

 
 

vi. Defining a segment (BCC): BCC is the ASCII converted value of the lowest 1 byte out of 

the ASCII value that adds from the header to the tail. Configure as 2 byte for the length, 

0 ~ 4 for segment range, SUM for check type and hexadecimal for ASCII data conversion. 
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4) Completing a sending frame definition: (TX frame of the continuous read command for the 

direct variable) Set the communication direction as sending frame, communication interval 

as 100msec and receiving frame for sending as RD_RX_1 as shown below. 
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5) Completing frame registration (Requesting continuous read of the direct variable and 

receiving the response frame). Communication can be established only by the protocol 

program without having a separate scan program. 
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7.2 DNP3 Protocol 

Distributed Network Protocol, DNP3, is a set of communications protocols mainly used in utilities 

such as electric and water companies. The CIMON DNP3 program is designed to connect the device 

defined in the DNP3 protocol to the PLC device. 

Registering the DNP3 program 

Select [File] → [New Program] → [DNP3] menu. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Writing the DNP3 program 

Example of writing a program:  

For configuring the DNP communication module device at local base, slot#1. 

 

 Set 5 words from X0000 in the Binary Input field. 

 Set 5 words from Y0100 in the Binary Output field. 

 Set Binary Output Type as Pulse On (Single) and Hand Off as 10x100ms (1 second). 

 Set 10 words from D00000 in the Counter field. 

 Set 20 words from D00100 in the Analog Input field. 

 Set 20 words from D00200 in the Analog Output field. 

 Set Hand Off in Analog Output as 10x100ms (1 second). 
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7.3 PLC Link (Public IP) Protocol 

When some PLC links use the public network, users can register IP and station number in the PLC 

Link (Public IP) Setting program in order to differentiate the IPs on the network using the station 

number. 

Registering the PLC Link (Public IP) Setting program 

Select [File] → [New Program] → [PLC Link (Public IP) Setting] menu. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Writing the PLC Link (Public IP) Setting program 

Example of writing a program: 

When configuring the common network using the Ethernet module at local base, slot #1. 

 Set the IP address of the mounted module as “100.100.100.1” and station number as 1. 

 Register the IP “100.100.100.2” in the station number 2. 

 Register the IP “100.100.100.3” in the station number 3. 

1) Click the [Add] button to display the “Add IP” window. 

Select the station number (1) in the “Add IP” window and enter the IP address 

(100.100.100.1). 
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2) Press the [Enter] key to register the IP address (100.100.100.1). 

 

 

3) Likewise, register the station numbers 2 and 3. 

 
 

 

7.4 Fieldbus Protocol 

When controlling the remote I/O using the internal PLC device in the Profibus DP or DeviceNet 

Master module, configure the I/O area using the fieldbus communication block setting program. 
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Registering the Fieldbus program 

Select [File] → [New Program] → [Fieldbus] menu. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 

 

Writing the Fieldbus program 

Example of writing a program: When controlling the remote I/O using the fieldbus (PD01A: Profibus 

DP) master module at local base, slot #2, the number of remote I/O connected to the fieldbus 

master is 32 point inputs and 16 point outputs. 

Select “Local” for Base, “2” for Slot, and “CM1-PD01A” for Module type. 
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In case of reading the input of the remote I/O and configuring to save 2 words (32 bit) from M0000. 

 

Select [Input] tab and click [Add New] button. 

 

Select “M” for Device Type, 0 for Star Address, and 2 for Buffer Size. Click [OK] button. 
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In case of setting 1 word (16 bit) data from Y0010 as the output of the remote I/O. 
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Select [Output] tab and click [Add New] button. 

 

Select “Y” for Device Type, 10 for Start Address, and 1 for Buffer Size. Click [OK] button. 

 

 

7.5 Modbus RTU Master Protocol 

The Modbus RTU Master program is used to define the communication block in order to read and 

write the data from and to the Modbus RTU Slave using the serial communication module. 
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Registering the Modbus RTU Master program 

Select [File] → [New Program] → [MODBUS/RTU Master] menu. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Writing the Modbus RTU Master program 

An example for controlling the MODBUS-RTU Slave using the Serial (SC0nn) module at local base, 

slot #0. 

 

Communication block that reads 5 data from the coil status (Start Address: 0) of the Slave (station 

number: 1) and saves it in 5 bits from M0005. 

Click [Add] button. 
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 Counterparty’s Station Number: (1) 

 Function: (01 Read Coil Status) 

 Point Number: (1) Enter the number that is bigger than Start Address by 1. 

 Data Type: If the data to read is bit, the data type is meaningless. 

 Data Count: (5) 

 Device: (M0005) 

 If you don’t select “Do not transmit automatically” option, the communication block will be 

automatically processed. 

 

Click [OK] button. 

 

Communication block that writes 4 words from D00000 at the Multiple Registers (Start Address: 0) 

of the Slave (station number: 1) 

 

Click [Add] button. 
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 Counterparty’s Station Number: (1) 

 Function: (16 Preset Multiple Registers) 

 Point Number: (1) Enter the number that is bigger than Start Address by 1. 

 Data Type: (INT16: High order byte first) 

 Data Count: (4) 

 Device: (D00000) 

 If you don’t select “Do not transmit automatically” option, the communication block will be 

automatically processed. 

 

Click [OK] button. 
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You can change the block locations using the [Up] and [Down] buttons. 
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7.6 Ethernet Protocol 

The Ethernet Protocol program enables the user to define the communication frame of the Ethernet 

communication module. 

 

Registering the Ethernet Protocol program 

Select [File] → [New Program] → [Ethernet Protocol] menu. 

 
Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Writing the Ethernet Protocol program 

An example program reads 5 words from D00100 of the counterparty’s CIMON PLC (100.100.100.20) 

using the dedicated service and saves it in 5 words from D00100 of CIMON PLC. Communication is 

established using the Ethernet communication module mounted in local base, slot #0. 
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1) Register a host:  

Register the PLC Ethernet card to read the data. Click [Add Host] button. 

 
 Communication Result: Enter the device (M0000) to save the communication result. 

 IP Address: Enter the counterparty’s IP (100.100.100.20) 

 Port Number: Enter the Port Number (10262) to use for communication. The port 

number in the dedicated service uses TCP (10260) and UDP (10262). Select “UDP.” 

 Click [OK] button. 

 

* Receive Header/Tail is used when the entire frame has a header and tail but receives as the header 

and tail are split. All frames are combined, from the time the header has been received to the time 

when the tail is received, to process as a frame (request or response). 
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2) Register a frame (Rx frame for the Word Block Read command): 

Select a host and click the [Insert Frame] button. The Frame Setting window will appear as 

below. 
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 Frame Name: Enter name to differentiate the frame. 

 Tx/Rx: Sets the communication direction – sending or receiving. 

 Auto receive frame: Specifies the frame that corresponds to the response.  

 Auto Send/Receive: Sending frames will be automatically sent at the specified 

interval. 

 

3) Define a frame (Rx frame for the Word Block Read command): 

Defines the frame contents to interpret the response frame to the Word Block Read request 

frame of CIMON PLC. 

 

i. Define a segment (ID): Sets the ID in the protocol.  

In this case, the ID for the dedicated service is “KDT_PLC_M” as shown below. 
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ii. Define a segment (Frame No.): Sets the frame number area in the protocol. 

Select “Don’t care” for the Segment Type since it is not related with the data. The area 

designated as “Don’t care” will not be compared. Length is 1 byte as shown below. 
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iii. Define a segment (Cmd): The command of the ACK response to the Word Block Read is 

52h as shown below. 

 
 

iv. Define a segment (Res: Reserved area 00h): The reserved area is 00h as shown below. 
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v. Define a segment (Data area: Requesting device): Since 5 words data from D00100 is 

requested, the requesting device of the response frame is received in D00100 as shown 

below. 

 
 

vi. Define a segment (Data area: Number of requesting data): The number of requesting 

data is received as 005h since 5 data has been requested. 
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vii. Define a segment (Data area: Receiving data): Since requested data is received 

sequentially, configure as shown below in order to save the received data in D00100 

sequentially. 

 
 

viii. Define a segment (Check Sum): The checksum area covers the entire frame area. 
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4) Complete defining a frame (Rx frame for Word Block Read): 

The communication direction is receiving frame as shown below. 

 
5) Define a frame (Tx frame for the Word Block Read command): 

Defines the request frame for Word Block Read. 

i. Define a segment (ID): Sets the ID in the protocol. 

The ID for the dedicated service is “KDT_PLC_M” as shown below. 
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ii. Define a segment (Frame No.): Sets the frame number area in the protocol. 

Length is 1 byte as shown below. 

 
 

iii. Define a segment (Cmd): The command to the Word Block Read is 52h as shown below. 
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iv. Define a segment (Res: Reserved area 00h): The reserved area is 00h as shown below. 

 
 

v. Define a segment (Data area: Requesting device): Since 5 words data from D00100 is 

requested, the requesting device of the response frame is received as D00100. Set as 

shown below. 
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vi. Define a segment (Data area: Number of requesting data): The number of requesting 

data is received as 0005h since 5 data is requested. 

 
 

vii. Define a segment (Check Sum): The checksum area covers the entire frame area. 
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6) Complete frame registration (Tx frame for Word Block Read): 

 
 

Set the communication direction as the sending frame. Also, set the automatic receiving frame 

after sending so that the system automatically awaits the receiving of the specified frame (0) 

after sending. Lastly, set the automatic sending interval as 0.1 second so that communication 

is established at every 0.1 second. 

 

7) Complete frame registration (Word Block Read request and response frame receiving) 



 

150 

 

CICON USER MANUAL 

 

Communication will be established by the protocol program without having another separate scan 

programming. 

 

7.7 HighSpeed Link (Ethernet) Protocol 

The Ethernet High Speed Link program is used when fast communication between CIMON PLCs is 

needed. This program allows each PLC to send and receive data of 64 stations, but sending stations 

are limited to 32 stations. There can be a maximum of 64 words executive data in a station. In order 

to enjoy the best performance, it should be separated with other networks. If it works with other 

networks, its network speed will be significantly reduced. 

Registering the HighSpeed Link(E) program  

Select [File] → [New Program] → [HighSpeed Link(E)] menu. 
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Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 

 

* Note: [PLC Link] in [Parameter] does not support High Speed PLC Link to PLC-S.  

Only [Ethernet High Speed Link] program in the Communication Configuration supports this function. 
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Communication modules compatible with [Ethernet High Speed Link] program are as follows: 

 PLC-S: All CPU modules with Ethernet Option 

 PLC-S: CM3-SP01EET (Ethernet Expansion module) 

 CP/XP: CM1-EC10A, CM1-EC10B 

 Note: CM1-EC01A of CP/XP series is not compatible with Ethernet option of CM2-BP series. 

 

High Speed PLC Link Port 

 Communication Port Number: UDP/IP 10264 

 

Writing the HighSpeed Link(E) program 

 

An example of using the Ethernet HighSpeed Link program: Communication is established between 

two modules where #1 PLC-S sends data which increases by +1 at every second to the device area 

D11 of #2 PLC-S. Then, the received data will be sent back to the device area D11 of #1 PLC-S. 

Likewise, this example includes 32 blocks of internal communication between these two PLC-S 

modules. 

1) Have two PLC-S modules ready and connected with two programs inside the CICON 

software. 
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2) Write a scan program that increases the data by +1 at every second as shown below. 

3) Below images are two separate Ethernet High Speed Link programs for two PLC-S modules.  

Set station numbers (Stn) as 0 and 1 for #1 PLC-S and #2 PLC-S respectively.  

Then, click on [Add] button. 

 

* #1 PLC-S Configuration                      * #2 PLC-S Configuration 

4) Block numbers for #1 PLC-S and #2 PLC-S must be the same in order to communicate. 

Configure so that TX block number of #1 PLC-S is identical with RX block number of #2 PLC-S 

as shown above. 

5) The address of the Block Number 0 will travel from Device D10 of #1 PLC-S and send data to 

D11 of #2 PLC-S as shown above. 

6) In the same way as above, you can add 32 blocks for each #1 PLC-S and #2 PLC-S. When you 

complete adding blocks, it will look like below image. 
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*HighSpeed PLC Link configuration for #1 PLC-S    *HighSpeed PLC Link configuration for #2 PLC-S 

 

TIP: PLC can send and receive a maximum of 64 data blocks while sending blocks are limited to 32. If 

the number of sending blocks exceeds 32, you will get an error message as shown below. 

 

7) When you’re done with configurations, download the programs into the #1 and #2 PLC-S 

respectively and see the communication results. 
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8) When you check the communication results, you can use Memory Monitor to see the online 

status of PLC-S while in RUN mode. 

 
* Communication results for D device area of #1 PLC-S 

 

 
* Communication results for D device area of #2 PLC-S 

 

7.8 Modbus TCP Master Protocol 

The Modbus/TCP Master program is used to exchange data with TCP Modbus Slave device and is 

compatible with CM1-EC10A and CM1-EC10B modules. 
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Registering the Modbus/TCP Master program 

Select [File] → [New Program] → [MODBUS/TCP Master] menu. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Writing the Modbus/TCP Master program 

This example shows communication system and frame configurations between CIMON-PLC and TCP 

Modbus Slave device. 

1) Register the Modbus/TCP Master program that will process the values of PV/SV from the 

Slave Device to the CIMON-PLC and configure communication parameters of the 

communication module. 

 
 

2) Fill out the Modbus/TCP Master program that configures the value of SV and reads the value 

of PV from the Slave Device to the CIMON-PLC. 

 

a. Register a connecting device 
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b. Register a communication block that reads the value of PV 

 
 

c. Register a communication block that controls the value of SV 

 

*Note: If you mark the checkbox “Do not transmit automatically,” then you have to use “SEND” 

command in the scan program to execute the same communication function. 
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d. Complete communication block registration 

(Comm. block No. 2 has been registered in order to read the value of SV at all times) 

 

3) Download the PLC program and then switch the PLC mode to RUN. 

 

7.9 CIMON-NET Master Protocol 

The CIMON-NET Master program is used to configure I/O device area for controlling Remote I/O 

with CIMON NET Master Module (CM1-CN01M). 

Registering the CIMON-NET Master program 

Select [File] → [New Program] → [CIMON-NET Master] menu. 
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Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 

 

Writing the CIMON-NET Master program 

This example applies to a case when CIMON-NET Master Module (CM1-CN01M) controls Remote IO 

and the module is mounted on local base, slot #1. The number of points for the Remote IO 

connected to the CM1-CN01M is 16 inputs and 16 outputs. 
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Configure communication setup for the Master Module. 

 Base: Local (Default) 

 Slot: 1 

 Module Type: CM1-CN01M (Default) 

 Master Module Station: 0 (Default) 

 Baud Rate: 125 (Default) 

 Time out: 200 (Default) 

 Polling time: 10 (Default) 

 

Click on [Write] button. 
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Click on [AUTO SCAN] button. 
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When the Remote I/O is detected after the [AUTO SCAN] as shown above, select [Input] tab under 

the [Data Block] and click on [Add] button in order to read input of the Remote I/O and save 1 Word 

(16bit) in M0000. 
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Select M for Device Type, 0 for Start Address and 1 for Buffer Size. 

Click on [OK] button. 
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Select [Output] tab under the [Data Block] and click on [Add] button in order to set the data of 1 

Word (16bit) from Y0010 as the output of the Remote I/O. 

 

Select Y for Device Type, 10 for Start Address and 1 for Buffer Size. 

Click on [OK] button. 

 

Click on [Write] button. 
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7.10 CIMON-NET Slave Protocol 

The CIMON-NET Slave program is used to exchange data between CIMON PLCs using CIMON-NET 

Master Module (CM1-CN01M) and CIMON-NET Slave Module (CM1-CN01S). 

Registering the CIMON-NET Slave program 

Select [File] → [New Program] → [CIMON-NET Slave] menu. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 

 

Writing the CIMON-NET Slave program 

Example of writing a program: 
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 Base: Local 

 Slot: 1 

 Module Type: CM1-CN01S 

 Station No: 0 

 Input: Register to send the 100 words data from M0000 to the master module. 

 Output: Register to receive the 50 words data from D00100 of the master module. 

 

-Input  

Click on [Input] tab → [Add] button. 

 

Select M for Device Type, 0 for Start Address and 100 for Buffer Size. 

Click [OK] button. 
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-Output 

Click on [Output] tab → [Add] button. 

 

Select D for Device Type, 100 for Start Address and 50 for Buffer Size. 

Click [OK] button. 

 

Click on [Write] button. 
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7.11 Security (User / IP) 

The Security program is used to register user ID, IP address and Mac address to allow only registered 

user, IP address and Mac address access the network or program such as Web Server. 

 

Example) Security setting for Web Server 

In order to build security on the web server, Security program must be configured. 

1) Right-click on the Program and choose New Program and then choose Security (User / IP). 

 

2) Security Setting 

Choose the security option that you want to use for web server. 
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- User ID : Only registered user ID can access the web server page with password.  

Maximum 16 ID can be registered. 

- IP Address : Only registered IP address can access the web server page. 

 Maximum 16 IP address can be registered. 

- MAC Address : Only registered PC can access the web server page. 

Maximum 16 MAC address can be registered. 

- Auto logout : Web page will be logged out after set time. 
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3) Click ID tab and click Add. 

 
Write ID name and click Check ID. 

You can choose 1 to 15 security level. (Level 1 is the top that you can access all levels of pages.) 

Example) Level 5 : Level 1 ~5 users can access web page. 

(If you want to use only ID and Password for web server, you don’t have to set up IP Address 

and Mac Address.) 

 

4) Click IP Address tab and click Add. 

 
Write the IP Address where you want to access the web server from. 

 

 

5) Click MAC Address tab and click Add. 

 
Write the Mac address of the PC where you want to access the web server from. 

* If you want to use those 3 types of security, choose User ID, User IP Address and User MAC Address. 

 

7.12 Web Server Security 

The Web Server Setting program is used to select user ID or/and IP address to allow only registered 

user or/and IP address can access the Web Server. 

*In order to use Web Server Setting program, Security (User / IP) program must be configured at first. 

 

1) Right-click on the Program and choose New Program and then choose Web Server Setting. 
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Choose the security option that you want to use for web server. 
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If you want to use either User ID or IP Address for web server security, they must be set up at the 

Security (User / IP) program at first. 

- User Security : Only registered ID can access web server page. 

- IP Address Security : Only registered IP address can access web server page. 

- Web Page Default Level : Choose security level from 1 to 15 (No.1 is the highest level) 

When page level in Web Server Manager is Default, this selected level will be default. 

Example) If you choose Level 5, the default of “Page level” will be level 5 too. 

 

*Online Edit : While you access web server, you can also edit security option. 

 

8. Special Program 

 
8.1 Special Card (Module) Initialization 

The Special Card Initialization Program saves the setting values of a special card as a scan program 

and provides the stored information automatically when there is a special card replacement that 

requires resetting without any additional operations of connecting to the CICON software. 

Registering the Special Card Initialization program 

Select [File] → [New Program] → [Special Card init] menu. 

*Only one Special Card Initialization Program can be registered for a project. 
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Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 

These are the benefits for using the Special Card Initialization Program: 

 After a special card replacement, you can write the default settings on the selected card just 

by switching the PLC mode from STOP to RUN. 

 You can recall the settings of the special card connected to the PLC in a single operation 

(Upload – automatic scan function). 

 Even if you’re not connected with PLC, you can still configure settings for a special card. 

(Offline editing function) 

 You can convert the Special Card Initialization Program into a scan program that can be 

edited. (IL Conversion function) 

 You can recall the setting values of I/O reservation and reflect those values for special card 

configuration (I/O Reservation Load function) 
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The Program Screen Configuration 

 
 In case of a non-response card, it is displayed as an empty slot. 

 If you’re not using a special card, the background color for a slot is grayed out as seen in the 

above image. 

 These are the list of special cards that can be used in this program. 

1. Ethernet module 

2. RS232C/422 module 

3. Logger module 

4. CDMA module 

5. BACNet module 

6. A/D conversion module 

7. D/A conversion module 

8. A/D D/A conversion module 

9. AD MUX module 

10. RTD conversion module 

11. TC conversion module 

12. High Speed Counter module 

 

Writing the Special Card Initialization Program 

1) Base Count: Select the number of base. The default value is 1 (Local), and you configure up 

to maximum of 17 (Local: 1/ Expansions: 16) bases. 

 



 

176 

 

CICON USER MANUAL 

*For Block PLC (BP) and PLCS, “Base Count” and “Base set” are fixed values due to restrictions on 

specifications. 

 Block PLC: Base Count “1,” Base set is 4. 

 PLCS: Base Count “1,” Base set is 12. 

 

*If you change the Base Count after configuring the special cards, the existing data can be deleted. 

2) Base set: Select the number of base slots. 

The default is “3” Slot, you can select 3 / 4 / 5 / 8 / 10 / 12 Slots. 

 

  *If you change the Base set after configuring the special cards, the existing data can be deleted. 

  *For Block PLC (BP) and PLCS CPU types, the Base set is fixed and cannot be selected. 

 

3) Upload (Automatic Scan): You recall the setting values of each card by connecting to the PLC. 

Before you upload, make sure to check CPU types and their communication configurations. 

When you upload, be aware that the existing data configurations will be initialized. 

*Assigned value for the Base I/O Address configured in the I/O Reservation cannot be erased. 

  

4) IL Convert: You can convert the Special Card Initialization program into IL program. 

Once you convert it to IL program, you cannot revert to the Special Card Initialization 

program. 
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After IL conversion: 

 

*Each slot is separated by its comment. (Comment will not be created for an empty slot or a non-

responsive card.) 

Modifying or editing in the LD Editing Window is not recommended. If you download the incorrect 

buffer memory and incorrect input and output settings to the PLC, this may cause a malfunction of 

the PLC. 

<<Precautions for Online Edit>> 
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If the output of one contact is greater than the maximum of 64, Online Edit may not work properly. 

In the “Special Card Initialization Program,” it is recommended that you separate the contacts on the 

basis of a maximum 32 steps for effective step management. 

5) Initialize: All the configured data will be erased. 

After the data initialization, the program will be set as the default configuration of “Local 

Base” and “3 Slot.” (Except for Block PLC / PLCS) 

*Even after the initialization, if you close the program without saving, you can still restore 

previous configurations. 

 
 

 

6) I/O Reservation Load: This brings I/O reservation settings. 

Use this function when you use I/O occupancy setup or there is start address value of the 

expansion base. 

 
*After the I/O Reservation Load, please set up a card individually. 

 

 

7) Save: Saves the setting values in a file. 

 
*If you close without saving, the lastly saved data will be kept. 
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8) Cancel: It closes the program. 

If you close the program without saving, a confirmation message is displayed as shown 

below. 

 
 

9) Detail Setting: It brings out setup window of a special card. If the slot is displayed as “-

“(empty or non-responsive) or “I/O 0, 16, 32, 64,” the Detail Setting button will not be 

activated. 

 

When a special card is selected, the Detail Setting button will be activated. 

*If you double-click the slot with the special card selected, Detail Setting window pops up. 

 

10) I/O Address Allocation (Expansion base only): Base I/O address allocation value configured 

in the Reserved IO (in red box) will be displayed in this function. 
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In order to use the “Base I/O address 

allocation” function, you have to follow 

these two steps: 

 

10.1) CICON → Reserved IO → Configure 

“Base I/O address allocation” 

 

10.2) Special card initialization program → 

Click “I/O Load.” 

 

 

*Even if you upload (automatic scan), you cannot reset “I/O Address allocation value.” 

*If you want to modify or delete, follow 10.1 and 10.2 steps. 

 

<Precautions for saving the value of “I/O Address Allocation”> 

*You have to configure at least one special card of the expansion base in order to save the value of 

“I/O Address Allocation” by clicking “IO Load” button. 

*If there are no special card configurations for local base or expansion base, the “I/O Address 

Allocation” value for the relevant base will not be saved. 

11) Special Card Setup: When you double-click the slot with the special card selected, the Detail 

Setting window pops up and lets you configure individual settings of each special card. 

Ex) D/A Module Setup 
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*Make sure to click “Save” after configurations. Otherwise, the configurations will not be 

reflected in the Special Card Initialization Program. 
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8.2 PID Control 

PID control is a control loop feedback mechanism in which the controller continuously calculates an 

“error value” as the difference between a measured process variable (PV) and a desired set point. 

 

Registering the PID Special Program 

PID Special Program must be registered only once for a CICON project, and it can have 32 Loops 

within one program. 
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Configure the PID Special Program 
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Number Item  Description  

(a) Number of Total Loops Because the system to be controlled is one, select ‘1.’ 

(b) Number of Loops  
Per Scan 

Since the total number of loops is one, select ‘1’ also. 

 
(c) 

 
PIDINIT Start Address 

Enter the start address in which PIDINIT setting values are stored.  
By changing the start address, the device of the setting items get 
automatically changed. 

 
(d) 

 
PIDCAL Start Address 

Enter the start address in which PIDCAL setting values are stored.  
By changing the start address, the device of the setting items get 
automatically changed. 

(e) Operation Type When the manipulated variable increases, so does the measurement 
value. Therefore, select the forward operation. 

 
 

(f) 

 
 

Sampling Time (Ts) 

If it is a system where measurement values are changed sensitively for 
the change of the manipulated variable, the sampling interval should be 
set short. For a general HVAC system in which the measurement values 
are insensitive to changes, the sampling interval can be set about 1 
second. 

 
(g) 

 
Proportional Gain (Kp) 

Enter the proportional gain value of the system. If the hunting of the 
value is severe, reduce the proportional value. In this test, the value is 
set to 30,000. 

 
(h) 

 
Integral Gain (Ki) 

Enter the integral gain value of the system. If the integral gain value is 
large, hunting gets reduced but the time to stabilize can be prolonged.  
In this test, the value is set to 20. 

 
(i) 

 
Derivative Gain (Kd) 

Enter the derivative gain value of the system. This value is used when 
there is severe disturbance or a system with a quick reaction. In this test, 
it is assumed that there is no serious impact of disturbance. Therefore, 
this value is set as ‘0 (Not Use).’ 

 
(j) 

 
Filter Coefficient (α) 

This value configures to what extent the filtering is going to be applied 
on the measurement values. The closer the value gets to 0, the less the 
filtering effect is. 

(k) MV Low Limit Enter the lowest limit of the manipulated variable. The value is set as 0 
in this test. 

 
(l) 

 
MV High Limit 

Enter the highest limit of the manipulated variable. Because it is a 
system in which the manipulated variable value can be outputted more 
than a specific value, the MV High Limit is set as 16,000 in this test. 

 
(m) 

 
MV Change Rate Limit 

Enter the manipulated variable variation rate limit. This value is used to 
prevent the change of the manipulated variable from occurring 
suddenly. Since this test requires no specific need to limit on the change 
of the manipulated variable, the value is set as 16,000. 

 
(n) 

 
MV Auto Apply 

This value is used when a user wants to keep the MV value when 
switching from automatic to manual mode. In this test, the value is set 
as ‘0 (Disabled).’ 

(o) SV Transition Step This value is used to control the time taken to reach the set value. In this 
test, the value is set as ‘0 (Disabled).’ 

 
(p) 

 
On/Off Time 

This value is used to control on/off time using the MV value. If a value 
more than 1 is entered for operation, the MV Low Limit and the MV High 
Limit will be outputted in turn as the manipulated variable. Because this 
test does not involve On/Off control, this value is set as ‘0 (Disabled).’ 

(q) SV(Set Value) Enter the target value that you want to control. (i.e.) ‘200’ is entered. 
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(r) 

 
 
 
 
 
 

 
PV(Process Value) 

Enter the process value of the control unit. You can configure the ERO 
module and enter the appropriate values as shown in the below dialog 
image in order to read the data directly. The memory address is set as ‘2’ 
in order to detect the temperature value of the channel 2 of the ERO 
module by reading the value from the current directly. As mentioned 
above, the Module Slot is set as ‘2’ (ERO module being in the second 
slot) and the Module Base is set as ‘0’ since there is no expansion base. 

 
 

 
 
 
 
 
 
 
 

 
 

(s) 

 
 
 
 
 
 
 
 
 
 

MV(Manipulation Value) 

The manipulated variable is the calculated result of the PID operation. 
You can either get this value by using the MOV command from the 
external scan program or configuring the DA card directly in order to 
output the MV value. Enter the value as shown below to use the DA card 
and to output the MV value directly in this test. 

 
The channel 2’s digital output value (DA) of the EAA module is 
configured as Memory Address ‘27’ (Please check the buffer memory of 
CM3-SP04EAA in the HELP file for the detailed information) in order to 
adjust the temperature value through the current. Also as mentioned 
above, the Module Slot is set as ‘1’ (EAA module being in the first slot) 
and the Module Base is set as ‘0’ since there is no expansion base. 

(t) Pvnt(After Filter) Only monitoring is possible. 

(u) MVman(MV Manual) Use this value when the manipulated variable value is set to manual 
mode.  

(v) Auto / Manual Selection This specifies the initial operating mode. In this test, it is ‘Auto Mode.’ 
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Write the Scan Program 

 

This scan program enables channel 1 and channel 2 outputs of the EAA module to operate directly.  

Refer to the table below for the input and output signals of the PLC-S (CM3)-SP04EAA-CPU. 

 

Signal direction (CPU ← A/D, D/A) Signal direction (CPU → A/D, D/A) 

Input Signal Name Output Signal Name 

X20   A/D module Ready Y20  

X21   Y21 

X22   Operating Condition Save Complete Y22   Operating Condition Save Command 

X23   CH.1 High Level Alarm Y23   DA CH.1 Output Enable 

X24   CH.2 High Level Alarm Y24   DA CH.2 Output Enable 

X25   CH.3 High Level Alarm Y25  

X26   CH.4 High Level Alarm Y26 

X27  Y27 

X28 Y28 

X29 Y29 

X2A Y2A 

X2B Y2B 

X2C Y2C 

X2D Y2D 

X2E Y2E 

X2F   D/A Module Error flag Y2F   Error Clear Command 
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Download and Control 

 

The fact that the blue LED of the “PID Loop Initialized” is turned ON signifies that the program is 

operating normally. 
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Enter the number ‘350’ for the Set Value (SV).  

The number ‘350’ signifies 35.0°C. When you want to have the value of 45.5°C, enter the number 

‘455.’ 
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Using Auto Tune Function 

 

The temperature control is possible by using the Auto Tune function. Depending on the response 

capability of the system, tuning operations can often be time consuming. 

Before the tuning operations, be sure to check whether the flag status of the loop is normal. When 

the tuning operations are completed, the current value of the proportional, integral, and derivative 

gain of the loop gets modified. 
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If you want to cancel the tuning operation, click the button “Stop Tune.” When the Auto Tune 

function is operating normally, the blue LED of the “Auto-tune Processing” gets turned ON. The 

target value should be set in a way that is in line with the operation type. In other words, it should 

be forward direction when the target value is greater than the current PV. It should be reverse 

direction if the target value is smaller than the current PV. The tuning operation will be automatically 

completed when the process value reaches about 68 percent of the error between the current PV 

and the target value. 
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Verify results with a trend graph 

 

Through the Trend function, it is possible to check the status of the SV (Set Value), PV (Process 

Value), and MV (Manipulation Value). 

In the image above, the red line signifies the SV while yellow line signifies the PV and the green line 

signifies the MV. In order to recognize the amount of variation with ease, the max value of the SV 

and PV is configured as 400. The max value of the MV is set as 17,000. 

After the setting value is set as 400, the current value is getting closer to the set value as the 

temperature changes according to the variation in the amount of MV. Once the PID program is fully 

stabilized, the current value and the set value almost remain the same without the difference 

between each other. When Auto Tuning is completed, you will get a message as shown below. 
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Executing AUTO TUNING in the Sequence Program 

a) Writing a Scan Program 

 

When writing a scan program, the conditional equation D2000 > D100 (direct action) must be 

satisfied. 

1) BSET   D16   5 activates the 5th bit of the device D16. 

What information is contained in the 5th bit of D16? 

The 5th bit is a flag used to start the Auto Tuning as the AUTO-TUNE CMD bit. 

 

2) MOV   D2000   D100 transfers the value of D2000 to D100. 

Why use D100? SV (Set Value) is written on the device D100. 

 

 
 

When you enter the desired value in D2000, the value of 350 will be written in the SV (D100). 

D2000 has been randomly assigned in this test and can be designated by the user as desired. 

However, it should be configured to avoid overlapping with other PIDCAL, PIDINIT addresses. 
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8.3 Thermistor Setting Program 

Thermistor module is used to measure the temperature by calibrating thermistor resister. 

a) Register the program 

Select [File] → [New Program] → [Thermistor]. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 

 

b) Writing a thermistor program. 

After registering the program, below box appears. 
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Register “Base” and “Slot” of the thermistor module. 

i. Setting Channels: Setting Tab is sued to set status, digital range, digital filter, average OP 

and Device. 
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● Drag a mouse, you can select many channels. 
● If you want only one channel, select a channel by clicking a mouse. 
● By using a ctrl-Key, you can select channels what you want. 
 

ii. Select [Edit] button. The below box appears. 

 
 

iii. Select [Enable] and you can change a value. 
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iv. Digital Range: It is used to convert the maximum and minimum temperature to a digital 

value according to a temperature converting table. 

 
 

v. Digital Filter: Used to set up in case of hunting by outside noise when converting 

temperature. It is restricted to converting ranges before storing converted temperature. 

 
Range of set value: 0~70% 

 

Example: Values which store the buffer memory are present values by adjusting digital filter. Preset 

Value = Present value + (formal value – present value) * Digital Filter(%)/100 
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vi. Average: Used to set up calibrating value for average time. 

 
Range of set value: 0~255 sec. 

 

vii. Device: Used to store converted temperature in CPU memory. 

 
Enable Domain: X, Y, M, L, K, D 

Type of stored data: Fahrenheit, Celsius, digital value 

 

Example: The above example shows that you can store Celcius value in D100. 
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Table Tab: It is used to input the temperature and resistance of a thermistor. 

 

Please register the values refer to temperature-resistance table by provided manual from thermistor 
cooperation. 

- 
Center P. temperature = Max. Temperature – (Max. Temperature – Min. Temperature)  / 
2 

  

- 
In case of inputting the temperature-resistance table incorrectly, converted temperature value is 
out of range (0.3%) 

  
   Example   :   Max. Temperature = 100℃, Min. temperature = -20℃ 

       100 – (100 - (- 20) / 2 = 100 – 60 = 40℃ 
  

- 
Register temperature values (Max. =  100℃, Center = 40℃, Min. = -20℃), and then Input 
resistance values of each temperature 
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Click [Status], and you can see the current status of the thermistor module. 
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8.4 Loadcell Setting Program 

The Loadcell Program configures parameters of the Loadcell modules including WG02A, WG04A, 

WG02C, WG02D and WG02E. 

Registering the Loadcell program 

Select [File] → [New Program] → [Loadcell] program. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Configuring the Loadcell program 

 

1) Weighing Mode: The Loadcell modules provide 8 different operating modes. 

• Indicator mode: is the simplest operating mode, provides the measured weight only and has no 

control functionality. 

• Automatic normal batching: A batch is weighed automatically by controlling the full flow and dribble 

flow signals. The batch control is started by ‘Start (Y2/3/4/5) signal or “WGBATCH” instruction. The 

batching data must firstly be configured by this special program (Loadcell) or written into the shared 

memory area of WG0nA module by sequence program. 

• Automatic loss in weight batching: A batch is weighed by measuring the loss in weight as the material 

is discharged from the weighing hopper. The batch control is started by ‘Start (Y2/3/4/5)’ signal or 

“WGBATCH” instruction. Also, this batch needs ‘Tare (YA/B/C/D)’ input from sequence program during 

the progress. 

• User controlled normal batching: This mode performs normal batch weighing but the comparator 

output is dependent only on the current weight data. This mode, while being more flexible than the 

automatic mode, is more difficult to implement as the full flow and dribble flow signals must be turned 

off by a sequence program before the hopper is discharged. No compensation is performed. 

• User controlled loss in weight batching: This mode performs loss in weight batching but the 

comparator output is dependent only on the net weight data. This mode, while being more flexible 

than the automatic mode described in section “Automatic Loss in Weight Batch,” is more difficult to 

implement. No compensation is performed in this mode. After starting of this mode, the batching 
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signal (X6/7/8/9) is turned on until when the WGSTOP instruction or ‘Batch Stop’ command (code 3) 

with Y2/3/4/5 signal is issued by sequence program. 

• Comparator mode: This mode performs only comparison between set values and net weight. 

• Weight sorting: This mode gets 7 different boundaries (set values) for classifying the 8 different 

ranges of weight. Each 8 ranges have their output bits in control outputs (offset 3, 18, 33, 48). At any 

time, only one bit of control outputs is set according to the currently measured net weight. 

• Dynamic batching (fluid): This dynamic weighing batch program is supported by WG02D model 

only. WG02D model is specially turned for weighing fluid objects such as eggs, filled bottles and etc. 

at high speed (typical speed: 0.5 sec). Measured weight of fluid object has a special characteristic 

that series of measured values have wave pattern. A measuring idea can be suggested by this 

characteristic. Actual weight of the object would be located at the middle point of minimum and 

maximum wave cycle approximately. 

 

2) Max. Weight: Maximum weight that the Loadcell can measure. 

3) Min. Scale: Sets the display digit span value. If set value was ‘5’, measured weight will be 

displayed as 0, 5, 10, and 15 … so on. 

4) Near Zero Range: If current measured weight is within the valid set range (within 1% of Max. 

Weight), the zero signal will be turned on. 

5) Digital Filter Constant: Valid set value (%) is 0-90%. WG0nA module has a digital filter for 

removing the noise from Loadcell output signal. 

6) Average Window Size and Time: The weight data that can be used in batch control and 

sequence program is the average of a number of AD samples. This parameter sets the 
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number of samples for the average and the sampling time between each sampled data. The 

number of samples used does not affect the update rate of the weight data because the 

average is a ‘moving window’ type. If the set value is zero, the averaging function will not be 

activated. 

7) Stable Range and Time: Valid set range is within 1% of Max. Weight while valid set time 

(unit of 100 msec) is 1 – 100 (100msec – 10,000msec). A weight which does not change 

within the specified range for the time specified is considered to be stable and the stable 

output will be set to ON. If one of these set values is zero, the stable detect function will not 

be activated. 

8) Auto Zero Range: Valid set range is within 1% of Max. Weight while valid set time (unit of 

100 msec) is 1 – 100 (100msec – 10,000msec). The auto zero function removes the zero drift 

in the system by periodically re-zeroing the measured weight when it is near zero. The auto 

zero range is the maximum zero shift that will be corrected and the time period is the 

minimum time between corrections. If the measured weight shifts from zero to a value 

outside the auto zero range (within the zero time period) the weight will not be re-zeroed. If 

one of these set values is zero, the auto zero function will not be activated. 

9) Hysteresis Range and Time: Valid set range is within 1% of Max. Weight while valid set time 

(unit of 100 msec) is 1 – 100 (100msec – 10,000msec). The hysteresis function suppresses 

flicker of the measured weight data. If the weight changes within the range specified and 

returns to the previous value within the time limit specified, the measured weight data will 

not be affected. If one of these set values is zero, the hysteresis function will not be 

activated. 
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8.5 High Speed Counter Program for PLC-S 

The HSC for PLC-S Program is a special program that configures and controls High Speed Counter 

function built in PLC-S CPU. 

 

Registering the HSC for PLC-S 

Select [File] → [New Program] → [HSC for PLC-S] program. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Configuring the HSC for PLC-S program 

 

 Start Address: The parameters of the High Speed Counter program are stored in M, L, K, D 

areas in which you specify. You cannot specify start address while in monitoring mode. 

Select the Start Address after shutting down the monitor mode. 

 
 

 Channel: Two channels are offered and can be selected. 
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 Monitor: Monitor mode is activated by clicking the “Monitor” button. 

 

 

 “Monitor Stop” button appears when the Monitor mode is activated. 

 

 Parameter: The parameters of each channel are listed in the below table. 

Oft Group Description 
Setting 

Memory Remark 
Value Function 

0 

Parameter 

Count Type 
H0000 Linear Counter 

Word  Read Only 
H0001 Ring Counter 

1 Input Pulse Mode 

H0000 2 Phase, 2 Input, 2 Multi. 

Word Read Only  
H0001 2 Phase, 2 Input, 4 Multi. 

H0002 1 Phase, 2 Multi. (Low) 

H0003 1 Phase, 2 Multi. (High) 

2 Compare Mode H0000 < Word   
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H0001 <= 

H0002 = 

H0003 => 

H0004 > 

H0005 < > 

H0006 > < 

3 
Int. Preset Value -2,147,483,648 ~ 2,147,483,647 Dword 

Low 

4 High 

5 
Ext. Preset Value -2,147,483,648 ~ 2,147,483,647 Dword 

Low 

6 High 

7 
Ring Max. Value -2,147,483,648 ~ 2,147,483,647 Dword 

Low 

8 High 

9 
Compare Max. -2,147,483,648 ~ 2,147,483,647 Dword 

Low 

10 High 

11 
Compare Min. -2,147,483,648 ~ 2,147,483,647 Dword 

Low 

12 High 

13 Compare Output 

HFFFF N/A 

Word Read Only 

H0000 Y0010 

H0001 Y0011 

H0002 Y0012 

H0003 Y0013 

H0004 Y0014 

H0005 Y0015 

H0006 Y0016 

H0007 Y0017 

14 Unit Time 1~60,000 mSec Word   

15 Pulse / Rotation 1~60,000 Pulse Word   

16 Control 

Counter Enable Bit 0 SET = Enable 

Word 

  

Int. Preset Bit 1 SET = Preset   

Ext. Preset Enable Bit 2 SET = Enable   

Down Counting Bit 3 SET = Down Read Only 

Compare Output 
Enable 

Bit 4 SET = Enable Read Only  

RPM / PPS Select Bit 5 RPM(1), PPS(0)   

Count Latch Bit 6 SET = Enable  Read Only 

  Bit 7..F     

17 

Monitor 

RPM/PPS 

Measured Value 

-2,147,483,648 ~ 2,147,483,647 Dword 

Low Word 

18 High Word 

19           

20 

Carry Bit 0 SET = Carry 

Word 

Read Only 

Borrow Bit 1 SET = Borrow Read Only 

Compare Result Bit 2 SET = Result Read Only 

  Bit 3..F     

21 
Current Count Value -2,147,483,648 ~ 2,147,483,647 Dword 

Low Word 

22 High Word 

23 Input Pulse per 

Unit Time 

-2,147,483,648 ~ 2,147,483,647 Dword 

Low Word 

24 High Word 

25 Error Code Refer Error Code Table Word   

 



 

208 

 

CICON USER MANUAL 

 Operation Status: displays status flags of High Speed Counter. 

 
 

 Save: 

When the HSC for PLC-S program is saved, a confirmation message appears as shown below. 

 
 

 Online Modify: You can modify and change values while running the program. Once saved, a 

confirmation message appears as shown below. 

 
 

 Close: closes the program. 
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8.6 Positioning Program for PLC-S 

The Positioning for PLC-S program is a special program that configures and controls positioning 

function built in PLC-S CPU. Only one positioning program for PLC-S can be registered for a CICON 

project. 

 

Registering the Positioning for PLC-S 

Select [File] → [New Program] → [Positioning for PLC-S] program. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Configuring the Positioning for PLC-S 

 

 Start Address: The parameters of the positioning program are stored in M, L, K, D areas in 

which you can specify. You cannot select start address while in monitoring mode. Specify 

the Start Address after shutting down the monitor mode. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

211 

 

CICON USER MANUAL 

 X/Y Axis Parameter Configurations: Because the parameter configurations are stored in the 

same space (flash memory) in which the sequence program is saved, the parameters will be 

kept even after power is removed. 

Off 
Set 

Item 
Configuration Details 

R/W Remark 
Default Function 

0 Output Pulse Type 0 
0=Not Used 
1=High Active 
2=Low Active 

W   

1 
Bias Speed at Start 1 1 ~ 100,000 PPS DW 

Low 

2 High 

3 
Speed Limit Value 50,000 1 ~ 100,000 PPS DW 

Low 

4 High 

5 ACC/DEC Time 1 1,000 1 ~ 65,535 mSec W   

6 ACC/DEC Time 2 1,000 1 ~ 65,535 mSec W   

7 ACC/DEC Time 3 1,000 1 ~ 65,535 mSec W   

8 ACC/DEC Time 4 1,000 1 ~ 65,535 mSec W   

9 
S/W Upper Limit 2,147,483,647 -2,147,483,648 ~ 2,147,483,647 DW 

Low 

10 High 

11 
S/W Lower Limit -2,147,483,648 -2,147,483,648 ~ 2,147,483,647 DW 

Low 

12 High 

13 
Speed Control 
Current Position 

0 
0=Do not update 
1=Update 
2=Clear and update 

W   

14 
Backlash 
Compensation 

0 0 ~ 65,535 Pulse W   

15 
External 
Upper/Lower Limit 
Signal 

0 
0=Not Used 
1=Wired (Used) 

W   

16 
Jog Speed Limit 20,000 

1 ~ 100,000 PPS 
(Bias Speed<Jog Speed<Speed Limit) 

DW 
Low 

17 High 

18 Jog Acc/Dec Time 0 No. of Acc/Dec Time (0~3) W   

19 Inching Speed 100 0 ~ 65,535 PPS W   

20 
Complete Output 
Signal Duration 

1000 0 ~ 65,535 mSec W   

21 OPR Method 0 
0=DOG / Zero OFF 
1=DOG / Zero ON 
2=DOG 

W   

22 OPR Direction 0 
0=Forward 
1=Backward 

W   

23 
Origin Address 0 -2,147,483,648 ~ 2,147,483,647 DW 

Low 

24 High 

25 
OPR High Speed 50,000 1 ~ 100,000 PPS DW 

Low 

26 High 

27 
OPR Low Speed 1,000 1 ~ 100,000 PPS DW 

Low 

28 High 

29 OPR Acc/Dec Time 0 No. of Acc/Dec Time (0~3) W   

30 DWELL Time 0 0 ~ 50,000 mSec. W    
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 X/Y Axis Position Data: The basic controls such as position control and speed control are 

executed by configuring the required items in this ‘Position Data’ and starting this position 

data. Maximum of 30 ‘position data’ can be defined for each axis. Each position data 

occupies 8 Word sized memory. This same structure of 8 word memory is also used for 

positioning command “POSCTRL.” 

 

*For Dwell Time / Operating Speed / Position Address, invariable numbers and device addresses  

(D, M, L, K) can be entered. 
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Off 
Set 

Item Bit Description Unit 

0 

Operation Pattern 
0 00 = Single step control 

01 = Continuous control 
  

1 

Axis to be Interpolated 
2 00 = Non-Interpolation 

01 = Main Axis : Y (Linear Interpolation) 
10 = Main Axis : X (Linear Interpolation) 

  
3 

ACC Time 
4 

Acc/Dec No. (0 ~ 3)   
5 

DEC Time 
6 

Acc/Dec No. (0 ~ 3)   
7 

Control System 8..F See ‘Control Code’ table   

1       

2 Dwell Time 0 ~ 65,535 or indirect data (device memory) mSec 

3       

4 
OPR Speed 

L 1 ~ 100,000 
or indirect data (device memory) 

PPS 
5 H 

6 Target Position Address L 
-2,147,483,648 ~ 2,147,483,647 
or indirect data (device memory) 

Pulse 

 

‘Control code’ must be 0 at the end of ‘position data’ list. While in operation, if the control code is 

zero, PLC-S terminates the series of positioning control and does not go onto the next item on the 

list. 

Code 
Sym Function Remark 

Hex Dec 

00H 0 - End of position data Terminates continuous control 

01H 1 ABS Absolute position control   

05H 5 INC Incremental position control   

09H 9 FEED 
Incremental position control after 
address reset 

  

13H 19 FSC Speed control (Forward)   

17H 23 RSC Speed control (Backward)   

80H 128 NOP No operation is performed.   

81H 129 JUMP Force to change next step No. 
Next step set value is stored in 
‘target position address’ 

82H 130 LOOP The first step of loop 
Loop count is stored in ‘target 
position address’ 

83H 131 LEND The last step of loop   

84H 132 POS 
Force to change the current 
position address 

New address is stored in ‘target 
position address’ 
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 Monitor: runs monitor mode. 

 
The monitor mode displays device information of the start address and contents of the axis. 

 
 AXIS: You can select either X Axis or Y Axis. When you change the axis, its device 

also changes, and the monitor window displays current state of the device. 

 

 ENABLE / DISABLE: 

Read: notifies the user whether or not the selected axis is currently active. 

Write: If this flag is set, the selected axis is switched to the active state. If the flag is 

reset, the axis is switched to the disabled mode. 

 

 Forward/Backward JOG: 

JOG drive operates forward and backward without a command, and it operates 

according to the ‘JOG Speed Limit’ and ‘JOG Accelerate / Decelerate Time’ values 

configured in the parameters. JOG motion can operate without having to 

determine starting point. *If you close the monitor window while driving JOG 

forward or JOG backward, be aware that the operating status is maintained. 
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 Decelerate (Dec) stop: gradually stops the axis in operation. 

 

 Emergency Stop: immediately stops the axis in operation without ‘decelerate 

section.’ 

 

 Error Reset: this button is activated when an error occurs during the operation of 

the selected axis. The error is displayed according to the error code below. 

Category 
Error 
Code Error Name Description 

- 0 No error Normal operation status 

Common 

104 H/W upper limit 
Exceeds position limit  
(H/W upper limit signal detected) 

105 H/W lower limit 
Exceeds position limit  
(H/W lower limit signal detected) 

106 Opr. speed error Operational speed in bigger than speed Limit 

154 S/W upper limit Exceeds S/W position upper limit 

155 S/W lower limit Exceeds S/W position lower limit 

  
156 Emergency Stop 

Positioning control is denied. 
(Emergency stop signal is ON) 

OPR 
202 OPR required 

Home position is not decided.  
Cannot execute positioning control. 

203 No DOG signal 
Exceeds DOG signal input time limit (30 seconds) during 
OPR operation. 

Manual 
300 JOG/Inching fault 

JOG/Inching command/input is executed while other 
positioning control is under operation. 

Positioning 

519 Interpolation fault Partner axis is busy with non-interpolation operation. 

550 
Position address 
change fault 

A command to change current position address is issued 
while the axis is under operation. 

551 Speed change fault 
A command to change current speed is issued while the 
axis in stop or dwell. 

552 
Target address change 
fault 

A command to change target address is issued while the 
axis in stop or dwell. 

553 
Duplicated position 
control 

Another position control command is issued while the 
axis is under operation. 

554 Online edit fault 
Online program edit/modify is performed while axis are 
under operation. 

 

 Save: When the Positioning for PLCS program is successfully saved, you will get a message. 

 

 Online Modify: downloads the positioning program while running the positioning program. 

When the modified program is successfully saved, you will get a confirmation message. 
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 Close:  closes the PLCS Positioning program. 

 

8.7 IO Input Filter for PLC-S 

The IO Input Filter Program is a special program that configures the IO Input Filter for PLC-S modules. 

 

Registering the IO Input Filter 

Select [File] → [New Program] → [IO Input Filter] program. 

 

Enter the Program Name, Program ID and Program Free Space (Online Edit Buffer). 

Click the [OK] button. 
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Configuring the IO Input Filter Program 

 

1) Base: There is no need to select base since PLC-S is fixed with local base. 

 

2) Slot: Select a slot to configure IO. A user can select from Slot 1 to Slot 12. 

 
 

3) Help: displays Help documentation of the IO Input Filter program. 

 

4) Input Filter Select: selects desired input contacts. “Select All” configures 32 points at once. 

There are two card types: 32 Point and 16 Point. 
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5) Standard Input Filter: Devices that are not selected in the ‘Input Filter Select’ will be drive 

cycle for the Standard Input Filter. You can enter up to 1~200. 

 

6) User Input Filter: Devices that are selected in the ‘Input Filter Select’ will be drive cycle for 

the User Input Filter. You can enter up to 1~200. 

 

7) Online Edit: You can edit the program while PLC is in RUN Mode. 

 

8) Write: saves the modified contents of the program. 

 

9) Close: closes the IO Input Filter program. Unless saved, the modified contents will be 

deleted. 

 

9. Special Module Configuration 

 
9.1 Ethernet Module Setting 

Establish Ethernet communication with the PLC. 

1) Basic Setup 

In order to connect PLC to HMI or access the project in the PLC through Ethernet, it is used to assign 

an IP Address to the Ethernet Communication Module. 

Applied Module: CM1-EC01A, CM1-EC10A, CM1-EC10B, CM1-EC10C, CM3-SP01EET. 
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Click Online → Special Module Setup and choose Ethernet Module or click Ethernet module on the 

Card Properties. 

 

i. If CPU is connected to CICON online, Base and Slot number display automatically. 

ii. If not, choose Base and Slot number where Ethernet module is installed. 

iii. Type IP Address, Subnet Mask and Gateway for your network. 

iv. If it is Modbus Slave, choose the Modbus Unit ID. 

v. Click Write to save the data. 

• Notice :  

In case of expansion base, communication module is recommended to be installed in Local base.  

If you need to install communication module in expansion base, only one communication 

module is recommended to be installed because communication speed (performance) should be 

decreasing. 
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2) DHCP Setup 

To connect CIMON SCADA and PLC via dynamic IP(DHCP), CM1-EC10C can be used. 

 

i. Choose the Base and Slot number where CM1-EC10C is installed. 

ii. Type System Name (Maximum 17characters). 

The System name must be different for each module because CIMON SCADA will use this 

name to find out correct module. 

iii. Type IP address to DDNS #1 and Port number. 

If SCADA is configured redundancy system, type IP address to DDNS #1 and #2. 

Both Port number must be the same with CIMON SCADA configuration. 

iv. Type DDNS Connection interval time. 

It is refresh time that PLC send its IP address to CIMON SCADA. 

If it is too short, system should have heavy load and if it too long, recovery should be 

delayed. 10 to 60 seconds would be recommended. 

v. Click [Write]. 
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• Tips 

If you click Status, you can find out module information. 

 

Version : Firmware version of module. 

Recent HMI Service : The last IP address that Ethernet module has connected to HMI. 

Recent Loader Service : The last IP address that Ethernet module has connected to CICON. 

Error Code : Refer to Ethernet module manual 

DHCP : If DHCP is configured, configuration will display. 

PLC Link Status : If PLC Link is connected, station number will be shown as blue color. 

 

9.2 Serial Module Setting 

Establish Serial communication with the PLC. 

1) RS232C Setup (Channel No. 1) 

In order to connect PLC to HMI or access the project in the PLC through Serial protocol, it is used to 

set parameter to Serial Communication Module. 

Applied Module : CM1-SC02A, CM1-SC01A, CM1-SC01B, CM1-SC02C, CM3-SP02ERS, CM3-SP02ERR 
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Click Online → Special Module Setup and choose RS232C/422 Module or click Serial module on the 

Card Properties. 

 

i. If CPU is connected to CICON online, Base and Slot number display automatically. 

ii. If not, choose Base and Slot number where Serial module is installed. 

iii. From the Communication type full-down menu, choose Null. 

iv. From the Protocol full-down menu, choose one of them. 

- Protocol Program : User can build his own protocol to communicate other device. 

- HMI Protocol : It makes PLC communicate with SCADA or XPANEL. 

- MODBUS RTU Protocol : It is for Modbus RTU Slave 

- PLC Link Protocol : It is used to make PLC Link 

- CICON (Loader) Protocol : It is used to connect CICON through RS232C port. You can 

download a project to the CPU module. 

- MODBUS Master Program : It is for Modbus RTU Master 

v.  Choose the Station number from 0 to 31. 

vi.  Choose each communication parameter. 

- Baud Rate : 300 to 76800 

- Parity : None, Even, Odd 

- Data Bit : 7 or 8 

- Stop Bit : 1 or 2 

- Response Delay : 0~ 200ms, Sending data frame is delayed as response delay time. 
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vii.  Click [Write] to save all parameters to module. 

 

2) RS422/RS485 Setup (Channel No.2 ) 

 

In order to use RS422 or RS485, set up Channel2. 

 

The configuration is the same with RS232C (Channel 1). 

i. Choose the Base and Slot number where the serial module is installed. 

ii. Type System Name (Maximum 17characters). 

The System name must be different for each module because CIMON SCADA will use this 

name to find out correct module. 

iii. Type IP address to DDNS #1 and Port number. 

If SCADA is configured redundancy system, type IP address to DDNS #1 and #2. 

Both Port number must be the same with CIMON SCADA configuration. 

iv. Type DDNS Connection interval time. 

It is refresh time that PLC send its IP address to CIMON SCADA. 

If it is too short, system should have heavy load and if it too long, recovery should be 

delayed. 10 to 60 seconds would be recommended. 

v. Click [Write]. 
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• Tips 

If you click Status, you can find out module information. 

 

Version : Firmware version of module. 

Error Code : Refer to Serial module manual 

PLC Link Status : If PLC Link is connected, station number will be shown as blue color. 

 

9.3 Data Logger Module Setting 

Data Logger (RS-232) Module 

1) RS232C Setup (Channel No.1) 

In order to connect data logger module to HMI, RS232 (CH1) must be configured first. 

Click Online → Special Module Setup and choose Data Logger (RS-232) Module or click Data Logger 

module on the Card Properties. 

Applied Module : CM1-LG32A 

RS232 configuration is the same way with Serial module setup. 
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i. If CPU is connected to CICON online, Base and Slot number display automatically. 

ii. If not, choose Base and Slot number where Serial module is installed. 

iii. From the Communication type full-down menu, choose Null. 

iv. From the Protocol full-down menu, choose one of them. 

- HMI Protocol : It makes PLC communicate with SCADA or XPANEL. 

- Terminal : Configuration, alarm, Delete and etc. can be possible by Hyper terminal 

v.  Choose the Station number from 0 to 31. 

vi.  Choose each communication parameter. 

- Baud Rate : 300 to 76800 

- Parity : None, Even, Odd 

- Data Bit : 7 or 8 

- Stop Bit : 1 or 2 

- Response Delay : 0~ 200ms, Sending data frame is delayed as response delay time. 

vii.  Click [Write] to save all parameters to module. 
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2) Log 

In order to read online data or logged data from connected HMI, set up Logging configuration. 

 

i. From the Log Type full-down menu, choose one of types. 

- Sampling : It collects data by sampling time that you set up. 

- Trigger : It collects data when PLC program asks. 

- Event : It collects data when the data status change. 

ii. Choose the sampling period. It is only used with Sampling log type. 

iii. If you want to delete data after sending data to HMI, select Delete sent data. 

iv. Double-click Device number in order to register logging data. 
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           - Device Type and Address : Choose the device type and starting device address. 

          (Word address is ok. EX: Y0000, Y0010, Y0100 and etc.) 

           - Data Type : Bit, Word(12Byte) and DWord(4Byte) 

           - Deadband / Bit : If Log type is Event, Deadband is standard value for changing value. 

            Regardless of Log type, selected bit will be logged. 

v.     Click [Write] to save configuration. 

 

9.4 DNP3 Ethernet Module Setting 

 

Establish DNP3 Ethernet communication with the PLC. 

1) Basic Setup 

In order to connect PLC to Host or access the project in the PLC through Ethernet, it is used to assign 

an IP Address to the DNP3 Communication Module. 

Applied Module : CM1-EC01DNP and CM1-EC04DNP 

Click Online → Special Module Setup and choose DNP3 (Ethernet) Module or click DNP3 (Ethernet) 

module on the Card Properties. 
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i. If CPU is connected to CICON online, Base and Slot number display automatically. 

ii. If not, choose Base and Slot number where Ethernet module is installed. 

iii. Type IP Address, Subnet Mask and Gateway for your network. 

iv. Click Write to save the data. 

• Notice :  

In case of expansion base, communication module is recommended to be installed in Local base.  

If you need to install communication module in expansion base, only one communication module is 

recommended to be installed because communication speed (performance) should be decreasing. 

 

2) DNP Setup 

To connect PLC to Host devices, set up DNP configuration as below. 

 

i. Click Enable and choose each Data Link Layers 

- DNP Address : Assign DNP number to DNP module. 

- Time-out(sec) : Choose the time-out second. 

- Retry : choose the number of retry. 

ii. Application Layer 

- Application Confirm : DNP module checks communication status from Host. 

It increases communication reliability but it also decreases communication speed. 

- Unsolicited Response : If an assigned data is changed, DNP module send this data to Host. 

iii. DNP Master 
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- DNP Address : Write HOST address 

- IP Address : Write IP address of HOST 

iv. Click Write. 

 

9.5 DNP3 Serial Module Setting 

Establish DNP3 Serial communication with the PLC. 

1) Basic Setup (Channel No. 1) 

In order to connect PLC to Host or access the project in the PLC through Ethernet, it is used to assign 

communication parameters to the DNP3 (RS232/422) Module. 

Applied Module: CM1-SC01DNP  

Click Online → Special Module Setup and choose DNP3 (RS232/422) Module or click DNP3 (RS232/422) 

module on the Card Properties. 

 

i. If CPU is connected to CICON online, Base and Slot number display automatically. 

ii. If not, choose Base and Slot number where Serial module is installed. 

iii. From the Communication type full-down menu, choose Null. (1:1 by cable) 

iv. Choose each communication parameter. 

- Baud Rate : 300 to 38400 

- Parity : None, Even, Odd 
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- Data Bit : 7 or 8 

- Stop Bit : 1 or 2 

- Response Delay : 0~ 200ms, Sending data frame is delayed as response delay time. 

(Response Delay time depends on HOST device. If response of SC01DNP is too fast, Host 

may not receive it. In this case, 50 mSec delay time would be recommended.) 

v. Click Write to save all parameters to module. 

 

2) DNP3.0 Setup 

To connect PLC to Host devices, set up DNP configuration as below. 

 

i. Click DNP3.0 tap and choose each Data Link Layers. 

- DNP Address : Assign DNP number to DNP module. 

- Time-out(sec) : Choose the time-out second. 

- Retry : choose the number of retry. 

ii. Application Layer 

- Application Confirm : DNP module checks communication status from Host. 

It increases communication reliability but it also decreases communication speed. 

- Unsolicited Response : If an assigned data is changed, DNP module send this data to Host. 

iii. DNP Master 

- DNP Address : Write HOST address 

iv. Click Write. 
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9.6 BACnet (Slave) Module Setting 

Establish BACnet (Slave) communication with the PLC. 

1) Basic Setup 

Applied Module : CM1-BN01A 

Click Online → Special Module Setup and choose BACnet (Slave) Module or click BACnet (Slave) 

module on the Card Properties. 

 

i. If CPU is connected to CICON online, Base and Slot number display automatically. 

ii. If not, choose Base and Slot number where Ethernet module is installed. 

iii. Type IP Address, Subnet Mask and Gateway for your network. 

iv. Click Write to save the data. 

• Notice :  

In case of expansion base, communication module is recommended to be installed in Local base.  

If you need to install communication module in expansion base, only one communication module is 

recommended to be installed because communication speed (performance) should be decreasing. 

 

 

 



 

232 

 

CICON USER MANUAL 

2) BACnet Setup 

To connect PLC to Master devices, set up BACnet configuration as below. 

 

In order to respond to Master, device must be registered in Object Type. 

i. Network Number : In order to distinguish each module in many BACnet modules on the 

same network, write network number. Master can find out Slave with this network 

number. 

ii. Click Add to register devices. 

Example) Analog Input 100word from D00400. 

 
iii. Click Write. 
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9.7 AD Module Setting 

In order to read analog input value from device, it is used to set analog input value range to assigned 

channels. 

Click Online → Special Module Setup and AD Module or click AD module on the Card Properties. 

CM1 AD module and CM3 AD module have different configuration window. 

Applied Module : CM1-AD04VI, CM1-AD08V, CM1-AD08I, CM1-AD04W and CM3-SP04EAO. 

■ CM1 AD module 

 

i. If you want to set all 4 channels at once, press Ctrl and click channels. 

ii. Click Setup and choose Input type, Digital value range, Signal Processing and Average Base. 

 Input Type : 4 - 20mA / 0 - 20mA / 1 - 5V / 0 - 5V / -10 - +10V / 0 - 10V / Disable 

 Digital Value Range : -192 - 16191 / -8192 - +8191 / 0 - 16000 / -8000 - +8000 

 Signal Processing : Average by samples / Average by time / Disable 

iii. Click Ok. 
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iv. Click Write to save parameter to PLC. 

v. Click to Read to check parameter. 

vi. If you click Status, you can see current value, minimum and maximum value, firmware 

version of module and error code. 

■ CM3 AD module 
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i. Double click Channel number 1 to open Channel Setup window. 

(If you want to set all 4 channels at once, press Ctrl and click channels.) 

ii. Choose each parameters. 

 Signal Type (Input type): 4 - 20mA / 0 - 20mA / 1 - 5V / 0 - 5V / -10 - +10V / 0 - 10V 

 Digital Range : -8192 - +8191 / -8000 - +8000 / -192 – 16191 / 0 – 16000 

 Filter Constant : 0 – 100% 

 Sampling Time : 0 – 2550mSec 

 Average Window size : 0 – 255 samples 

 High Alarm Value: in the Digital conversion value range. 

 Low Alarm Value: in the Digital conversion value range. 

iii. Click OK. 

 

iv. Click Write to save parameter to PLC. 

 

9.8 DA Module Setting 

In order to write analog output value to device, it is used to set analog output value to assigned 

channels. 

 

Click Online → Special Module Setup and DA Module or click DA module on the Card Properties. 

CM1 DA module and CM3 DA module have different configuration window. 
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Applied Module : CM1-DA04V, CM1-DA04VA, CM1-DA08V, CM1-DA08VA, CM1-DA04I and CM1-DA08I. 

CM3-SP04EOAI and CM3-SP04EOAV 

■ CM1 DA module 

 

Base and Slot number will appear automatically if CICON connects to PLC. 

i. If you want to set all 4 channels at once, press Ctrl and click channels. 

ii. Click Enable and choose Digital Value Range and STOP mode output. 

 Digital Value Range : -192 - 16191 / -8192 - +8191 

 STOP mode output: Clear or Hold 

Clear - If CPU mode is STOP, the last value will be output. 

Hold – If CPU mode is STOP, ‘0’ value will be output. 

iii. Click OK. 
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iv. Click Write to save parameter to PLC. 

v. Click Read to check parameter. 

vi. If you click Status, you can see current value, minimum and maximum value, firmware 

version of module and error code. 

■ TIP : Channel Enable or Disable setting 

1. Check PLC is RUN mode. 

2. Click Status and double-click Channel number 1. 
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3. Choose Enable and click OK. 

4. If PLC is turned ON, enable for all 4 channels are remained. 

Example) 

 

 H0001 : DA module slot number 

 23 : Buffer memory 23 for DA output Enable or Disable setting 

 H000F : choose channel to Enable output (CH1~CH8) 

 1: Data word to save in buffer memory 

5. Click Set value and choose the Output value and click OK. 

 

 

■ CM3 DA module : CM3-SP04EOAI, CM3-SP04EOAV 
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1. Double click Channel number 1 to open Channel Setup window. 

(If you want to set all 4 channels at once, press Ctrl and click channels.) 

 

2. Click Enable and choose each parameters. 

 Digital Value Range : 0 - 16000 / -8000 - +8000 / 0 – 10000(Percentage) 

 STOP mode output : Clear, Hold, Half Level or Max. Level 

 Output signal : 0 – 10 / -10 - 10 (Only SP04EOAV(Voltage) has this parameter.) 

3. Click OK. 
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4. Click Write to save parameter to PLC. 

 

9.9 ADDA Module Setting 

In order to read analog input value and write analog output value, it is used to set analog input and 

output value to assigned channels. 

Click Online → Special Module Setup and AD/DA Module or click ADDA module on the Card Properties. 

Applied Module : CM3-SP04EAA 

■ AD Channel Setting 

 

Base and Slot number will appear automatically if CICON connects to PLC. 

i. Double click Channel number 1 to open Channel Setup window. 

(If you want to set all 2 channels at once, press Ctrl and click channels.) 

ii. Choose each parameters. 

 Signal Type (Input type): 4 - 20mA / 0 - 20mA / 1 - 5V / 0 - 5V / -10 - +10V / 0 - 10V  

 Digital Range : -8192 - +8191 / -8000 - +8000 / -192 – 16191 / 0 – 16000 

 Filter Constant : 0 – 100% 

 Sampling Time : 0 – 2550mSec 

 Average Window size : 0 – 255 samples 

 High Alarm Value: in the Digital conversion value range. 

 Low Alarm Value: in the Digital conversion value range. 

 Resolution : 14bits or 16bits 
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iii. Click OK. 

 

iv. Click Write to save parameter to PLC. 

 

■ DA Channel Setting 

 

i. Double click Channel number 1 to open Channel Setup window. 

(If you want to set all 2 channels at once, press Ctrl and click channels.) 
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ii. Click Enable and choose each parameters. 

 Digital Value Range :  14Bit → 0 - 16000 / -8000 - +8000 / 0 – 10000(Percentage) 

16Bit → 0 – 64000 / -32000 - +32000 / Signal value (Current/Voltage) / 0 – 10000 (Percentage) 

 Output Type : 4 - 20mA / 0 - 20mA / 1 - 5V / 0 - 5V / -10 - +10V / 0 - 10V / 

 STOP mode output : Clear, Hold, Half Level or Max. Level 

Clear - If CPU mode is STOP, the last value will be output. 

Hold – If CPU mode is STOP, ‘0’ value will be output. 

 Resolution : 14bits or 16bits 

iii. Click OK. 

iv. Click Write to save parameter to PLC. 

 

9.10 AD MUX Module Setting 

In order to read analog value from other sensors, it is used to set analog input value to assigned 

channels. 

Click Online → Special Module Setup and AD MUX Module or Analog MUX module on the Card 

Properties. 

Applied Module : CM3-SP04EAM 

 

■ AD MUX Module Setup 

 

Base and Slot number will appear automatically if CICON connects to PLC. 

i. Click Channel 1. (If you want to set all 4 channels at once, press Ctrl and click channels) 

ii. Click Enable and choose Relay ON Time. 
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iii. Click OK. 

 

iv. Click Write to save parameter to PLC. 

v. Click Read to check parameter. 

vi. If you click Counter Reset, the selected channel will be reset. 

vii. If you want to change Auto Mode to Manual Mode, click Auto Mode. 
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Click Yes, then Manual Mode appears. 

 

 

9.11 RTD Module Setting 

In order to read temperature value and convert it to digital value, it is used to set parameter to 

assigned channels. 

 

Click Online → Special Module Setup and RTD Module or click RTD module on the Card Properties. 

Applied Module : CM1-RD04A, CM1-RD04B and CM3-SP04ERO 
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■ Channel Setting 

Example) PT100 sensor is connected to each Channel 1 and 2 and you want to measure temperature 

for 2 seconds and convert average value by 0~16000. 

 

Base and Slot number will appear automatically if CICON connects to PLC. 

i. Double click Channel number 1 to open Channel Setup window. 

(If you want to set all 4 channels at once, press Ctrl and click channels.) 

ii. Choose each parameters. 

 RTD Type : PT100, JPT100, PT1000, NI1000(DIN43760), NI1000(TER5000), Disable 

 Digital Value Range : -192 - 16191, -8192 - +8191, 0 – 16000, -8000 - +8000 

 Average : Choose the seconds 

iii. Click OK. 
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iv. Click Write to save the parameters. 

 

■ Scale Setup 

Example) Channel 1 : 0°C ~ 200°C Scale 

 

i. Temp. Unit : Choose °C 

ii. Temperature at 0 : 0°C 
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iii. Temperature at 16000 : 200°C 

iv. Click OK. 

 

 

9.12 TC Module Setting 

In order to read temperature value and convert it to digital value, it is used to set parameter to 

assigned channels. 

 

Click Online → Special Module Setup and TC Module or click TC module on the Card Properties. 

Applied Module : CM1-TC04A, CM3-SP04ETO 

 

■ Channel Setting 

Example) K type sensor is connected to each Channel 1 and 2 and you want to measure temperature 

for 4 seconds and convert average value by 0~16000. 
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Base and Slot number will appear automatically if CICON connects to PLC. 

i. Double click Channel number 1 to open Channel Setup window. 

(If you want to set all 4 channels at once, press Ctrl and click channels.) 

ii. Choose each parameters. 

 TC Type : K, J, E, T, R, S, B, N, and Disable 

 Digital Value Range : -192 – 16191 or  -8192 - +8191 

 Offset(-1000 ~ 1000) : Write offset value of measured temperature. (Buffer memory 5-8) 

Example) If you write 300, Offset will be +30°C. (300 x 0.1°C) 

 Digital Filter : Write percentage from  range 1 to 70% 

 Average : Choose the seconds 

iii. Click OK. 
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iv. Click Write to save the parameters. 

 

■ Scale Setup 

Example) Channel 1 : -100°C ~300°C Scale to 0~16000 

 

i. Temp. Unit : Choose °C 
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ii. Temperature at 0 : -100°C 

iii. Temperature at 16000 : 300°C 

iv. Click OK. 

 

 

9.13 High Speed Counter Module Setting 

It is used to set parameter of HSC channels. 

 

Click Online → Special Module Setup and High Speed Counter Module or click High Speed Counter 

module on the Card Properties. 

Applied Module : CM1-HS02C, CM1-HS02E, CM1-HS02F 

 

■ Channel Setting 

Example) Counter mode : Linear with 1 Phase and 1Multiple 
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Base and Slot number will appear automatically if CICON connects to PLC. 

i. From the Counter Mode full-down menu, choose Linear Counter 

ii. Type value each Preset, Comparison 1 and Comparison 2. If Preset buffer memory is ON, 

preset value will become current value. 

iii. Counter Type : choose Not Count. Only if Counter Enable and Counter Start are turned 

ON , Counter will get started. 

iv. Click Write to save the parameters. 

v. Click Status to check status of each channels. 
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9.14 Loadcell Module Setting 

It is used to see the status of each channels. 

Click Online → Special Module Setup and Loadcell Module or click Load Cell on the Card Properties. 

 

In order to set parameters of loadcell channels, create Loadcell program at the Special Configuration 

as below. For more details, refer to here. (Loadcell – Basic Configuration with Special Program) 
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Applied Module: CM1-WG02A, CM1-WG04A, CM1-WG02C, CM1-WG02D, CM1-WG02E 
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■ Load Cell 

 

• Total Weight : Total weight that Loadcell module measures appears. 

• AD Raw Value : AD conversion value dispaly 

• Zero Weight : Zero Command(Y06~Y09) is ON, total weight will become 0. 

• Batching : it shows status of Batch program. You can start and stop batch program. 

• Tare Weight : When Tare BIT(Y0A~Y0D) is turned Off and On, current total weight becomes 0. 

• Error : It shows error code. 

• Command Code : It shows Command main code. 

• Zero Reset : If you click it, total weight will become 0 and display it to Zero Weight (Offset5, 20,35 

and 50.) 

•  Tare Reset : If you click it, total weight will become 0 and display it to Tare Weight (Offset10, 25, 

40 and 55) 

• Status Flag : If Flag is ON, assigned bit will be turned Yellow. 

• Control Output : If Flag is ON, assigned bit will be turned Yellow. 
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9.15 PLC-S IO Module Setting 

You can find out slot number and firmware version of PLC-S Digital IO module. 

Click Online → Special Module Setup and PLC-S IO Module or click Digital module on the Card 

Properties. 

Applied Module : CM3-SP32EDO, SP32EOT, SP32EOC, SP32EDT, SP16DOR, SP16EDR 

 

Example) If you click Output_32P(TR Sink) module, it shows slot number2 and firmware version 3.00. 

 

10.  Device Monitoring 

 

By registering the desired device, you can monitor the value of constantly changing devices in real 

time. 
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How to Run Device Monitoring 

Select [View] → [Device Monitoring] menu. 

 

 

Device Monitoring Configuration 

When you select the Device Monitoring, it will be displayed in the right corner of the CICON software 

program. If you select ‘Variable Window’ along with Device Monitoring, it will also be displayed in the 

right corner next to the Device Monitoring. 
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*When there are no registered devices, only ‘Setup’ and ‘Insert’ buttons will be activated. 
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 Four tabs of Device Monitor can each have 32 devices and select the ones to monitor. 

 Once a device is registered, the device can be changed into the desired type and monitored 

in real time.  

 If the last address of the Bit device ends with 0, the value of Dword and Word can be changed.  

 If the last address does not end with 0, then the device can only be registered as bit device. 

Y device cannot be changed into another type. 
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How to Insert a Device in multiple ways 

1) You can insert and register a device in a scan program. 

 

 

2) Insert a device by right-click in the Device Monitoring tab. 
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3) Register a device by clicking ‘Insert’ button at the bottom of the Device Monitoring tab. 

 

*When inserting a device, there are 6 types available (Bit, Float, ASCII, Word, HEX, DWORD). 

* If the last address of the Bit device ends with 0, the device can be Dword and Word types. 

* If the last address does not end with 0, then the device can only be monitored as bit device. 

 
*A duplicate device cannot be registered. However, a same device address with a different 

device type can be registered and monitored in redundancy. 
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* If the last address of the Bit device ends with 0, all types can be selected. 

 
 

*If the last address of the Bit device does NOT end with 0, only BIT type can be selected. 
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How to Delete a Device in multiple ways 

1) Delete a device by clicking ‘Delete’ button at the bottom of the Device Monitoring tab. 

2) Delete a device by right-click in the Device Monitoring tab. 

3) Delete a device by clicking ‘All Delete’ button. 

 

4) Specify area and select a desired device or multiple devices. Click “Delete” on the 

keyboard. 
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How to Name Device Monitoring Tab 

By clicking ‘Setup’ button on the bottom of the Device Monitoring; you can easily name the tab. 

A maximum of 16 letters can be entered for each tab name. 

 

 

How to Modify a Device and its Type 

By double-clicking a desired device, you can modify its address and device type. 
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How to Write and Apply Value to a Device 

*Devices F, TS, TC cannot be written. 

1) Select Write: enables a user to write one value and apply to all devices at once. 

As you can see in the example below, the value of 200 was written to D19, X100 and M100. 

 

2) Write All: Each differently written value can be applied to each device at once.  

For example, each value (200, 1, 200) was applied to D19, X100, and M100 respectively. 
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3) Write value individually: Not using ‘Select Write’ and ‘Write All’ functions, a user can write 

value to a device individually by typing in a desired value and pressing ‘Enter.’ 

 

*Unless you press ‘Enter,’ the written value will not be applied to a selected device. 
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11.  CICON Simulator 

 

1) After creating new project, click [Tool] → [Connection Setup] and then select ‘PLC Simulator’ 

at the Type. 

 
 

2) After making logic ladder, click [Tool] → [Run PLC Simulator] 
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3) Click ‘PLC OFF’ and click [Tool] → [PLC TYPE] to select modules. 

 

If you have expansion Base, select number of Base at the Exp. Set. 

According to number of module, select slot number. 

4) Put your mouse on the slot and click right button of mouse and Module Set. 
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5) Select a module Type and Model. 

 
 

6) After selecting modules, click ‘PLC ON’ and then click [Online]  [Connect] at the CICON. 

Click [Download] to download all configuration and logic ladder to Simulator. 
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7) If download is completed, Card Properties has the same configuration with Simulator. 
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8) If you double click module at the Simulator, you can see the memory monitor just like CICON. 
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9) In order to turn Simulator off, Disconnect CICON from Simulator first. 

[Disconnect] at the CICON. 

 

 

 

 




